summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorReuben Thomas <rrt@sc3d.org>2016-12-18 19:06:54 +0000
committerHubert Figuière <hub@figuiere.net>2016-12-19 23:14:08 -0500
commite531961f06e9a491cd5f39160fce21224fd9a9d8 (patch)
treec971a3f8f9a01da42e30cb703ae3ce447eff3f08 /src/Makefile.am
parent08787dfa91d788bb84237cfffc8b44c11114e257 (diff)
downloadenchant-e531961f06e9a491cd5f39160fce21224fd9a9d8.tar.gz
Modernise autotools use: use configure.ac and autoreconf
Explain use of autoreconf in HACKING, and also make some other minor updates to that file.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7fa7b1a..4d79e73 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,6 @@
SUBDIRS=. aspell ispell uspell myspell hspell applespell voikko zemberek
-INCLUDES=-I$(top_srcdir) $(ENCHANT_CFLAGS) $(CC_WARN_CFLAGS) -DENCHANT_GLOBAL_MODULE_DIR=\"$(libdir)/enchant\" -DENCHANT_GLOBAL_ORDERING=\"$(datadir)/enchant\" -D_ENCHANT_BUILD=1 -DENCHANT_VERSION_STRING=\"@ENCHANT_MAJOR_VERSION@.@ENCHANT_MINOR_VERSION@.@ENCHANT_MICRO_VERSION@\"
+AM_CPPFLAGS=-I$(top_srcdir) $(ENCHANT_CFLAGS) $(CC_WARN_CFLAGS) -DENCHANT_GLOBAL_MODULE_DIR=\"$(libdir)/enchant\" -DENCHANT_GLOBAL_ORDERING=\"$(datadir)/enchant\" -D_ENCHANT_BUILD=1 -DENCHANT_VERSION_STRING=\"@ENCHANT_MAJOR_VERSION@.@ENCHANT_MINOR_VERSION@.@ENCHANT_MICRO_VERSION@\"
lib_LTLIBRARIES = libenchant.la
@@ -20,7 +20,7 @@ libenchant_includedir = $(includedir)/enchant
libenchant_include_HEADERS = enchant.h enchant-provider.h enchant++.h
if WITH_APPLESPELL
-INCLUDES += @APPLESPELL_CFLAGS@
+AM_CPPFLAGS += @APPLESPELL_CFLAGS@
libenchant_la_LIBADD += @APPLESPELL_LIBS@
libenchant_la_LDFLAGS += @APPLESPELL_LDFLAGS@
libenchant_la_SOURCES += enchant_cocoa.m enchant_cocoa.h