summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorReuben Thomas <rrt@sc3d.org>2017-04-29 22:40:32 +0100
committerReuben Thomas <rrt@sc3d.org>2017-04-30 17:49:59 +0100
commitfd306d6f364690037e01527e9398f69b33218db6 (patch)
treeeec4be8edac193a052c664a3ff1ac4de237ddb65 /configure.ac
parenta1167a25f2c0a22d18c5f3cb6b19e044d3f7d950 (diff)
downloadenchant-fd306d6f364690037e01527e9398f69b33218db6.tar.gz
Get AppleSpell back-end working again, and add list_dicts method
It transpired that owing to a problem in configure.ac, the backend was not being built, even on macOS. Fix this. As a result, some compilation errors recently introduced emerged. Fix them. Note that AppleSpell.config wasn't being installed. Fix this. Also fix its loading: it was being looked for in pkglibdir, but should be installed in pkgdatadir (and now is). In order to find the config file, promote enchant_get_conf_dirs to enchant-provider.h, which now therefore needs to include glib.h again.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 34144c0..bf00516 100644
--- a/configure.ac
+++ b/configure.ac
@@ -264,7 +264,9 @@ ENCHANT_CHECK_PKG_CONFIG_PROVIDER([hunspell], [HUNSPELL])
ENCHANT_CHECK_LIB_PROVIDER([aspell], [ASPELL], [get_aspell_dict_info_list])
ENCHANT_CHECK_LIB_PROVIDER([hspell], [HSPELL], [hspell_get_dictionary_path],, [-lz])
ENCHANT_CHECK_PKG_CONFIG_PROVIDER([voikko], [VOIKKO], [libvoikko])
-if test "$ac_cv_env_OBJCXX_value" != ""; then
+dnl FIXME: The test below assumes GCC(-compatible) ObjC++ compiler, but
+dnl OBJCXX is set even if no compiler is found.
+if test "$ac_cv_objcxx_compiler_gnu" = "yes"; then
AC_LANG_PUSH([Objective C++])
ENCHANT_CHECK_LIB_PROVIDER([applespell], [APPLESPELL], [NOLIB],, [-framework Cocoa], [Cocoa/Cocoa.h])
AC_LANG_POP([Objective C++])