summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in129
1 files changed, 47 insertions, 82 deletions
diff --git a/configure.in b/configure.in
index f6741087b9c..6a57e8ca60e 100644
--- a/configure.in
+++ b/configure.in
@@ -412,13 +412,27 @@ dnl quotation begins
machine='' opsys='' unported=no
case "${canonical}" in
+ ## GNU/Linux ports
+ *-*-linux-gnu*)
+ opsys=gnu-linux
+ case ${canonical} in
+ alpha*) machine=alpha ;;
+ s390-*) machine=ibms390 ;;
+ s390x-*) machine=ibms390x ;;
+ powerpc*) machine=macppc ;;
+ sparc*) machine=sparc ;;
+ ia64*) machine=ia64 ;;
+ m68k*) machine=m68k ;;
+ x86_64*) machine=amdx86-64 ;;
+ esac
+ ;;
+
## FreeBSD ports
*-*-freebsd* )
opsys=freebsd
case "${canonical}" in
alpha*) machine=alpha ;;
amd64-*|x86_64-*) machine=amdx86-64 ;;
- arm*) machine=arm ;;
ia64-*) machine=ia64 ;;
i[3456]86-*) machine=intel386 ;;
powerpc-*) machine=macppc ;;
@@ -447,13 +461,9 @@ case "${canonical}" in
case "${canonical}" in
alpha*) machine=alpha ;;
x86_64-*) machine=amdx86-64 ;;
- arm-*) machine=arm ;;
- hppa-*) machine=hp800 ;;
i[3456]86-*) machine=intel386 ;;
m68k-*) machine=m68k ;;
powerpc-*) machine=macppc ;;
- mips-*) machine=mips ;;
- mipse[bl]-*) machine=mips ;;
sparc*-) machine=sparc ;;
vax-*) machine=vax ;;
esac
@@ -465,8 +475,6 @@ case "${canonical}" in
case "${canonical}" in
alpha*) machine=alpha ;;
x86_64-*) machine=amdx86-64 ;;
- arm-*) machine=arm ;;
- hppa-*) machine=hp800 ;;
i386-*) machine=intel386 ;;
powerpc-*) machine=macppc ;;
sparc*) machine=sparc ;;
@@ -474,14 +482,6 @@ case "${canonical}" in
esac
;;
- alpha*-*-linux-gnu* )
- machine=alpha opsys=gnu-linux
- ;;
-
- arm*-*-linux-gnu* )
- machine=arm opsys=gnu-linux
- ;;
-
## Apple Darwin / Mac OS X
*-apple-darwin* )
case "${canonical}" in
@@ -503,24 +503,14 @@ case "${canonical}" in
## HP 9000 series 700 and 800, running HP/UX
hppa*-hp-hpux10.2* )
- machine=hp800 opsys=hpux10-20
+ opsys=hpux10-20
;;
hppa*-hp-hpux1[1-9]* )
- machine=hp800 opsys=hpux11
+ opsys=hpux11
CFLAGS="-D_INCLUDE__STDC_A1_SOURCE $CFLAGS"
;;
- hppa*-*-linux-gnu* )
- machine=hp800 opsys=gnu-linux
- ;;
-
## IBM machines
- s390-*-linux-gnu* )
- machine=ibms390 opsys=gnu-linux
- ;;
- s390x-*-linux-gnu* )
- machine=ibms390x opsys=gnu-linux
- ;;
rs6000-ibm-aix4.[23]* )
machine=ibmrs6000 opsys=aix4-2
;;
@@ -534,11 +524,6 @@ case "${canonical}" in
machine=ibmrs6000 opsys=aix4-2
;;
- ## Macintosh PowerPC
- powerpc*-*-linux-gnu* )
- machine=macppc opsys=gnu-linux
- ;;
-
## Silicon Graphics machines
## Iris 4D
mips-sgi-irix6.5 )
@@ -551,10 +536,6 @@ case "${canonical}" in
;;
## Suns
- sparc-*-linux-gnu* | sparc64-*-linux-gnu* )
- machine=sparc opsys=gnu-linux
- ;;
-
*-sun-solaris* \
| i[3456]86-*-solaris2* | i[3456]86-*-sunos5* \
| x86_64-*-solaris2* | x86_64-*-sunos5*)
@@ -594,11 +575,6 @@ case "${canonical}" in
esac
;;
- ## IA-64
- ia64*-*-linux* )
- machine=ia64 opsys=gnu-linux
- ;;
-
## Intel 386 machines where we don't care about the manufacturer.
i[3456]86-*-* )
machine=intel386
@@ -607,7 +583,6 @@ case "${canonical}" in
*-darwin* ) opsys=darwin
CPP="${CC-cc} -E -no-cpp-precomp"
;;
- *-linux-gnu* ) opsys=gnu-linux ;;
*-sysv4.2uw* ) opsys=unixware; NON_GNU_CPP=/lib/cpp ;;
*-sysv5uw* ) opsys=unixware; NON_GNU_CPP=/lib/cpp ;;
*-sysv5OpenUNIX* ) opsys=unixware; NON_GNU_CPP=/lib/cpp ;;
@@ -615,32 +590,6 @@ case "${canonical}" in
esac
;;
- ## m68k Linux-based GNU system
- m68k-*-linux-gnu* )
- machine=m68k opsys=gnu-linux
- ;;
-
- ## Mips Linux-based GNU system
- mips-*-linux-gnu* | mipsel-*-linux-gnu* \
- | mips64-*-linux-gnu* | mips64el-*-linux-gnu* )
- machine=mips opsys=gnu-linux
- ;;
-
- ## AMD x86-64 Linux-based GNU system
- x86_64-*-linux-gnu* )
- machine=amdx86-64 opsys=gnu-linux
- ;;
-
- ## Tensilica Xtensa Linux-based GNU system
- xtensa*-*-linux-gnu* )
- machine=xtensa opsys=gnu-linux
- ;;
-
- ## SuperH Linux-based GNU system
- sh[34]*-*-linux-gnu* )
- machine=sh3 opsys=gnu-linux
- ;;
-
* )
unported=yes
;;
@@ -669,7 +618,11 @@ if test $unported = yes; then
Check `etc/MACHINES' for recognized configuration names.])
fi
-machfile="m/${machine}.h"
+if test -n "$machine"; then
+ machfile="m/${machine}.h"
+else
+ machfile=
+fi
opsysfile="s/${opsys}.h"
@@ -936,7 +889,7 @@ case "$opsys" in
gnu-linux)
## cpp test was "ifdef __mips__", but presumably this is equivalent...
- test "$machine" = "mips" && LD_SWITCH_SYSTEM="-G 0"
+ case $host_cpu in mips*) LD_SWITCH_SYSTEM="-G 0";; esac
;;
netbsd)
@@ -2097,8 +2050,8 @@ AC_SUBST(LIBXTR6)
dnl FIXME the logic here seems weird, but this is what cpp was doing.
dnl Why not just test for libxmu in the normal way?
LIBXMU=-lXmu
-case "$machine" in
- ## These machines don't supply Xmu.
+case $opsys in
+ ## These systems don't supply Xmu.
hpux* | aix4-2 )
test "X$ac_cv_lib_Xmu_XmuConvertStandardSelection" != "Xyes" && LIBXMU=
;;
@@ -3155,8 +3108,14 @@ AC_SUBST(C_SWITCH_X_SYSTEM)
AC_SUBST(CFLAGS)
## Used in lwlib/Makefile.in.
AC_SUBST(X_TOOLKIT_TYPE)
-AC_SUBST(machfile)
-AC_SUBST(opsysfile)
+if test -n "${machfile}"; then
+ M_FILE="\$(srcdir)/${machfile}"
+else
+ M_FILE=
+fi
+S_FILE="\$(srcdir)/${opsysfile}"
+AC_SUBST(M_FILE)
+AC_SUBST(S_FILE)
AC_SUBST(GETLOADAVG_LIBS)
AC_SUBST(ns_appdir)
AC_SUBST(ns_appbindir)
@@ -3169,8 +3128,10 @@ AC_DEFINE_UNQUOTED(EMACS_CONFIGURATION, "${canonical}",
[Define to the canonical Emacs configuration name.])
AC_DEFINE_UNQUOTED(EMACS_CONFIG_OPTIONS, "${ac_configure_args}",
[Define to the options passed to configure.])
-AC_DEFINE_UNQUOTED(config_machfile, "${machfile}",
- [Define to the used machine dependent file.])
+if test -n "$machfile"; then
+ AC_DEFINE_UNQUOTED(config_machfile, "${machfile}",
+ [Define to the used machine dependent file.])
+fi
AC_DEFINE_UNQUOTED(config_opsysfile, "${opsysfile}",
[Define to the used os dependent file.])
@@ -3434,16 +3395,18 @@ if test "x$GCC" = "xyes" && test "x$ORDINARY_LINK" != "xyes"; then
gnu-*)
## armin76@gentoo.org reported that the lgcc_s flag is necessary to
## build on ARM EABI under GNU/Linux. (Bug#5518)
- ## Note that m/arm.h never bothered to undefine LIB_GCC first.
- if test "$machine" = "arm"; then
+ case $host_cpu in
+ arm*)
LIB_GCC="-lgcc_s"
- else
+ ;;
+ *)
## FIXME? s/gnu-linux.h used to define LIB_GCC as below, then
## immediately undefine it again and redefine it to empty.
## Was the C_SWITCH_X_SITE part really necessary?
## LIB_GCC=`$CC $C_SWITCH_X_SITE -print-libgcc-file-name`
LIB_GCC=
- fi
+ ;;
+ esac
;;
## Ask GCC where to find libgcc.a.
@@ -3525,7 +3488,9 @@ AH_BOTTOM([
/* Include the os and machine dependent files. */
#include config_opsysfile
-#include config_machfile
+#ifdef config_machfile
+# include config_machfile
+#endif
/* GNUstep needs a bit more pure memory. Of the existing knobs,
SYSTEM_PURESIZE_EXTRA seems like the least likely to cause problems.
@@ -3678,7 +3643,7 @@ Configured for \`${canonical}'.
Where should the build process find the source code? ${srcdir}
What operating system and machine description files should Emacs use?
- \`${opsysfile}' and \`${machfile}'
+ \`${opsysfile}' and ${machfile:+\`${machfile}'}${machfile:-none}
What compiler should emacs be built with? ${CC} ${CFLAGS}
Should Emacs use the GNU version of malloc? ${GNU_MALLOC}${GNU_MALLOC_reason}
Should Emacs use a relocating allocator for buffers? ${REL_ALLOC}