summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 3 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index 6c7231c5265..f73b73209e8 100644
--- a/configure.in
+++ b/configure.in
@@ -2589,7 +2589,7 @@ AH_BOTTOM([
#define CANNOT_DUMP
#endif
-/* PENDING: These are used for the Carbon port only. */
+/* TODO: These are used for the Carbon port only. */
#undef MAC_OS
#undef MAC_OSX
@@ -2645,7 +2645,6 @@ AH_BOTTOM([
# ifdef NS_IMPL_GNUSTEP
/* See also .m.o rule in Makefile.in */
# define C_SWITCH_X_SYSTEM -MMD -MP -D_REENTRANT -fPIC -fno-strict-aliasing
-# define LD_SWITCH_SITE -lgnustep-gui -lgnustep-base -lobjc $(CONFIG_SYSTEM_LIBS) -lpthread
# define GNU_OBJC_CFLAGS -fgnu-runtime -Wno-import -fconstant-string-class=NSConstantString -DGNUSTEP_BASE_LIBRARY=1 -DGNU_GUI_LIBRARY=1 -DGNU_RUNTIME=1 -DGSWARN -DGSDIAGNOSE
# define OTHER_FILES ns-app
# else /* NS_IMPL_COCOA */
@@ -2654,25 +2653,12 @@ AH_BOTTOM([
# endif /* NS_IMPL_COCOA */
#endif /* HAVE_NS */
-
-
-/* If no remapping takes place, static variables cannot be dumped as
- pure, so don't worry about the `static' keyword. */
-#ifdef NO_REMAP
-#undef static
-#endif
-
/* Define `subprocesses' should be defined if you want to
have code for asynchronous subprocesses
(as used in M-x compile and M-x shell).
- These do not work for some USG systems yet;
- for the ones where they work, the s/SYSTEM.h file defines this flag. */
+ Only MSDOS does not support this. */
-#ifndef VMS
-#ifndef USG
-/* #define subprocesses */
-#endif
-#endif
+#define subprocesses
/* SIGTYPE is the macro we actually use. */
#ifndef SIGTYPE