summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index e107508fb2a..0f1545e125d 100644
--- a/configure.in
+++ b/configure.in
@@ -190,8 +190,8 @@ case "${canonical}" in
alpha-dec-osf* )
machine=alpha opsys=osf1
# This is needed to find X11R6.1 libraries for certain tests.
- NON_GCC_TEST_OPTIONS=-Wl,-rpath,/usr/X11R6/lib
- GCC_TEST_OPTIONS=-Wl,-rpath,/usr/X11R6/lib
+ NON_GCC_LINK_TEST_OPTIONS=-Wl,-rpath,/usr/X11R6/lib
+ GCC_LINK_TEST_OPTIONS=-Wl,-rpath,/usr/X11R6/lib
;;
alpha-*-linux-gnu* )
@@ -975,6 +975,16 @@ then
CC="$CC $NON_GCC_TEST_OPTIONS"
fi
+if test x$GCC = xyes && test "x$GCC_LINK_TEST_OPTIONS" != x
+then
+ ac_link="$ac_link $GCC_LINK_TEST_OPTIONS"
+fi
+
+if test x$GCC = x && test "x$NON_GCC_LINK_TEST_OPTIONS" != x
+then
+ ac_link="$ac_link $NON_GCC_LINK_TEST_OPTIONS"
+fi
+
#### Some other nice autoconf tests. If you add a test here which
#### should make an entry in src/config.h, don't forget to add an
#### #undef clause to src/config.h.in for autoconf to modify.