summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 97c21d9804e..0452c255271 100644
--- a/configure.in
+++ b/configure.in
@@ -1281,10 +1281,17 @@ UNEXEC_SRC="`echo ${unexec} | sed 's/\.o/.c/'`"
# Do the opsystem or machine files prohibit the use of the GNU malloc?
# Assume not, until told otherwise.
GNU_MALLOC=yes
-if test "${system_malloc}" = "yes"; then
+doug_lea_malloc=yes
+AC_CHECK_FUNC(malloc_get_state, ,doug_lea_malloc=no)
+AC_CHECK_FUNC(malloc_set_state, ,doug_lea_malloc=no)
+if test "$doug_lea_malloc" = "yes" ; then
+ GNU_MALLOC_reason="
+ (Using new Doug Lea's new malloc from the GNU C Library.)"
+ AC_DEFINE(DOUG_LEA_MALLOC)
+elif test "${system_malloc}" = "yes"; then
GNU_MALLOC=no
GNU_MALLOC_reason="
- (The GNU allocators don't work with this system configuration.)"
+ (The GNU allocators don't work with this system configuration.)"
fi
if test x"${REL_ALLOC}" = x; then