summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 3 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index ba944e6cebd..4d9ba9636d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -402,12 +402,9 @@ AC_ARG_WITH(gameuser,dnl
An argument prefixed by ':' specifies a group instead.])])
gameuser=
gamegroup=
-# We don't test if we can actually chown/chgrp here, because configure
-# may run without root privileges. lib-src/Makefile.in will handle
-# any errors due to missing user/group gracefully.
case ${with_gameuser} in
- no) ;;
- "" | yes) gamegroup=games ;;
+ '' | no) ;;
+ yes) gamegroup=games ;;
:*) gamegroup=${with_gameuser#:} ;;
*) gameuser=${with_gameuser} ;;
esac
@@ -1966,7 +1963,6 @@ CLIENTRES=
CLIENTW=
W32_RES_LINK=
EMACS_MANIFEST=
-UPDATE_MANIFEST=
if test "${with_w32}" != no; then
case "${opsys}" in
cygwin)
@@ -2034,7 +2030,6 @@ if test "${HAVE_W32}" = "yes"; then
# the rc file), not a linker script.
W32_RES_LINK="-Wl,emacs.res"
else
- UPDATE_MANIFEST=update-game-score.exe.manifest
W32_OBJ="$W32_OBJ w32.o w32console.o w32heap.o w32inevt.o w32proc.o"
W32_LIBS="$W32_LIBS -lwinmm -lgdi32 -lcomdlg32"
W32_LIBS="$W32_LIBS -lmpr -lwinspool -lole32 -lcomctl32 -lusp10"
@@ -2054,7 +2049,6 @@ AC_SUBST(W32_OBJ)
AC_SUBST(W32_LIBS)
AC_SUBST(EMACSRES)
AC_SUBST(EMACS_MANIFEST)
-AC_SUBST(UPDATE_MANIFEST)
AC_SUBST(CLIENTRES)
AC_SUBST(CLIENTW)
AC_SUBST(W32_RES_LINK)
@@ -5432,7 +5426,7 @@ AC_SUBST(SUBDIR_MAKEFILES_IN)
dnl You might wonder (I did) why epaths.h is generated by running make,
dnl rather than just letting configure generate it from epaths.in.
dnl One reason is that the various paths are not fully expanded (see above);
-dnl eg gamedir=${prefix}/var/games/emacs.
+dnl e.g., gamedir='${localstatedir}/games/emacs'.
dnl Secondly, the GNU Coding standards require that one should be able
dnl to run 'make prefix=/some/where/else' and override the values set
dnl by configure. This also explains the 'move-if-change' test and