summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d5e802a961f..097c3bc68af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4145,6 +4145,10 @@ AC_SUBST(LIBS_TERMCAP)
AC_SUBST(TERMCAP_OBJ)
# GNU/Linux-specific timer functions.
+# Bug#34618.
+if test "$opsys" = "cygwin"; then
+ emacs_cv_have_timerfd=no
+fi
AC_CACHE_CHECK([for timerfd interface], [emacs_cv_have_timerfd],
[AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM([[#include <sys/timerfd.h>