summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ce386f6c6c8..262f367f2c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -774,6 +774,17 @@ fi
dnl This is used in lib/Makefile.am to use nt/gnulib.mk, the
dnl alternative to lib/gnulib.mk, so as to avoid generating header files
dnl that clash with MinGW.
+case $opsys in
+ mingw32 )
+ GNULIB_MK='$(srcdir)/nt/gnulib.mk'
+ ;;
+ * )
+ GNULIB_MK='$(srcdir)/lib/gnulib.mk'
+ ;;
+
+esac
+AC_SUBST([GNULIB_MK])
+
AM_CONDITIONAL([BUILDING_FOR_WINDOWSNT], [test "x$opsys" = "xmingw32"])
# Avoid gnulib's tests for -lcrypto, so that there's no static dependency on it.