summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a1deb7b0dde..6d204b61030 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1335,7 +1335,9 @@ if test -n "$BREW"; then
fi
# Check MacPorts on macOS.
-AC_PATH_PROG(HAVE_MACPORTS, port)
+if test $opsys = darwin; then
+ AC_PATH_PROG(HAVE_MACPORTS, port)
+fi
## Require makeinfo >= 4.13 (last of the 4.x series) to build the manuals.
: ${MAKEINFO:=makeinfo}