summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorFrancesco Potortì <pot@gnu.org>2003-03-16 22:30:36 +0000
committerFrancesco Potortì <pot@gnu.org>2003-03-16 22:30:36 +0000
commitb83dbf96cc8f43c0f97c50166cf2ca1df686b1b8 (patch)
tree00cd6bfae48f286e1405157796f117733c6a74d9 /configure.in
parentb0227a5af07c7082bf7f76a61d3cb06b426ce30a (diff)
downloademacs-b83dbf96cc8f43c0f97c50166cf2ca1df686b1b8.tar.gz
Check for need for bigtoc support on IBM AIX for
solving a linker table overflow problem.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b4c473ac102..e3c756b4224 100644
--- a/configure.in
+++ b/configure.in
@@ -1685,6 +1685,22 @@ else
HAVE_XFREE386=no
fi
AC_MSG_RESULT($HAVE_XFREE386)
+
+dnl Check for need for bigtoc support on IBM AIX
+
+case ${host_os} in
+aix*)
+ AC_CACHE_CHECK([for -bbigtoc option], [gdb_cv_bigtoc], [
+ case $GCC in
+ yes) gdb_cv_bigtoc=-Wl,-bbigtoc ;;
+ *) gdb_cv_bigtoc=-bbigtoc ;;
+ esac
+
+ LDFLAGS=$LDFLAGS\ $gdb_cv_bigtoc
+ AC_TRY_LINK([], [int i;], [], [gdb_cv_bigtoc=])
+ ])
+ ;;
+esac
# Change CFLAGS and CPPFLAGS temporarily so that C_SWITCH_X_SITE gets
# used for the tests that follow. We set them back to REAL_CFLAGS and