summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRichard M. Stallman <rms@gnu.org>2003-07-29 17:41:12 +0000
committerRichard M. Stallman <rms@gnu.org>2003-07-29 17:41:12 +0000
commit9467b8ec371e2d241cc2aebc219e6ce83f546dae (patch)
treeb7ed47c490a891b45684f7b00e335c2cc8266170 /configure.in
parentf549c801352dd3e69ded867b4ecc692591ed176e (diff)
downloademacs-9467b8ec371e2d241cc2aebc219e6ce83f546dae.tar.gz
(HAVE_XIM): Define if XIM is available.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 14 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index b0d012e64e7..33bad1a13e1 100644
--- a/configure.in
+++ b/configure.in
@@ -1248,6 +1248,7 @@ dnl checks for programs
AC_PROG_LN_S
AC_PROG_CPP
AC_PROG_INSTALL
+AC_PROG_GNU_LD
if test "x$RANLIB" = x; then
AC_PROG_RANLIB
fi
@@ -2066,14 +2067,24 @@ if test "${with_toolkit_scroll_bars}" != "no"; then
fi
fi
-dnl Don't use X11 input methods if user specifies he doesn't want it
-dnl with `--with-xim=no'.
+dnl See if XIM is available.
+AC_TRY_COMPILE([
+ #include <X11/Xlib.h>
+ #include <X11/Xresource.h>],
+ [XIMProc callback;],
+ HAVE_XIM=yes
+ AC_DEFINE(HAVE_XIM, 1, [Define to 1 if XIM is available]),
+ HAVE_XIM=no)
+
+dnl `--with-xim' now controls only the initial value of use_xim at run time.
if test "${with_xim}" != "no"; then
AC_DEFINE(USE_XIM, 1,
[Define to 1 if we should use XIM, if it is available.])
fi
-if test "${HAVE_X11}" = "yes"; then
+
+
+if test "${HAVE_XIM}" != "no"; then
late_CFLAGS=$CFLAGS
if test "$GCC" = yes; then
CFLAGS="$CFLAGS --pedantic-errors"