summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRichard M. Stallman <rms@gnu.org>2004-03-21 14:31:21 +0000
committerRichard M. Stallman <rms@gnu.org>2004-03-21 14:31:21 +0000
commit352e8ef500fe299079f7523983e7edc7567937c6 (patch)
treef9095b4badda5ab9a88aee62e5481d47507acf96 /configure.in
parent5b8bc596c29e52f0d72ed0767852e8e65ba42aa4 (diff)
downloademacs-352e8ef500fe299079f7523983e7edc7567937c6.tar.gz
Fix previous change.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 8f80608f4a7..3e89bea0c2d 100644
--- a/configure.in
+++ b/configure.in
@@ -1276,8 +1276,15 @@ fi
dnl We need -znocombreloc if we're using a relatively recent GNU ld.
dnl If we can link with the flag, it shouldn't do any harm anyhow.
dnl (Don't use `-z nocombreloc' as -z takes no arg on Irix.)
+dnl Treat GCC specially since it just gives a non-fatal `unrecognized option'
+dnl if not built to support GNU ld.
+
late_LDFLAGS=$LDFLAGS
-LDFLAGS="$LDFLAGS -znocombreloc"
+if test $GCC = yes; then
+ LDFLAGS="$LDFLAGS -Wl,-znocombreloc"
+else
+ LDFLAGS="$LDFLAGS -znocombreloc"
+fi
AC_MSG_CHECKING([For -znocombreloc])
AC_LINK_IFELSE([main(){return 0;}],