summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJan Djärv <jan.h.d@swipnet.se>2003-11-16 16:09:07 +0000
committerJan Djärv <jan.h.d@swipnet.se>2003-11-16 16:09:07 +0000
commit05b922b85feb74e0a9951fb142c3ce109ba978e3 (patch)
treeadc8a64f6ab6a87a94d9e0537786d9cfe40735bc /configure.in
parent453fc4fef5b94ad00dcdfb986bc01f6767370198 (diff)
downloademacs-05b922b85feb74e0a9951fb142c3ce109ba978e3.tar.gz
* configure.in (HAVE_GTK_MULTIDISPLAY): Check if GTK can handle
multiple displays. Regenerate configure.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 3add836efc4..5a3c296d57e 100644
--- a/configure.in
+++ b/configure.in
@@ -1915,13 +1915,24 @@ if test "${with_gtk}" = "yes" || test "$USE_X_TOOLKIT" = "gtk"; then
AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)
C_SWITCH_X_SITE="$C_SWITCH_X_SITE $GTK_CFLAGS"
+ CFLAGS="$CFLAGS $GTK_CFLAGS"
+ LIBS="$GTK_LIBS $LIBS"
HAVE_GTK=yes
AC_DEFINE(HAVE_GTK, 1, [Define to 1 if using GTK.])
USE_X_TOOLKIT=none
- dnl GTK scrollbars resembles toolkit scrollbars alot, so to avoid
+ dnl GTK scrollbars resemble toolkit scrollbars a lot, so to avoid
dnl a lot if #ifdef:s, say we have toolkit scrollbars.
with_toolkit_scroll_bars=yes
+
+ dnl Check if we can use multiple displays with this GTK version.
+ dnl If gdk_display_open exists, assume all others are there also.
+ HAVE_GTK_MULTIDISPLAY=no
+ AC_CHECK_FUNCS(gdk_display_open, HAVE_GTK_MULTIDISPLAY=yes)
+ if test "${HAVE_GTK_MULTIDISPLAY}" = "yes"; then
+ AC_DEFINE(HAVE_GTK_MULTIDISPLAY, 1,
+ [Define to 1 if GTK can handle more than one display.])
+ fi
fi
dnl Do not put whitespace before the #include statements below.