summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKaroly Lorentey <karoly@lorentey.hu>2007-04-22 12:12:29 +0000
committerKaroly Lorentey <karoly@lorentey.hu>2007-04-22 12:12:29 +0000
commite18c709364b095ea0be8ecabe458ac9a642a252f (patch)
treeefe814a842f932f387b3947c572bf43a548d17ef /configure.in
parent81088e260b086fe28f36964f32b6338210ec6fd8 (diff)
parent9f25e707aaad5ed14a9448e9c5d345ff0bdbc5a7 (diff)
downloademacs-e18c709364b095ea0be8ecabe458ac9a642a252f.tar.gz
Merged from emacs@sv.gnu.org
Patches applied: * emacs@sv.gnu.org/emacs--devo--0--patch-660 Update from CVS * emacs@sv.gnu.org/emacs--devo--0--patch-661 Merge from gnus--rel--5.10 * emacs@sv.gnu.org/emacs--devo--0--patch-662 Update from CVS * emacs@sv.gnu.org/emacs--devo--0--patch-663 Update from CVS * emacs@sv.gnu.org/emacs--devo--0--patch-664 Update from CVS * emacs@sv.gnu.org/emacs--devo--0--patch-665 Update from CVS * emacs@sv.gnu.org/emacs--devo--0--patch-666 Fix read-only prompt problem in isearch * emacs@sv.gnu.org/emacs--devo--0--patch-667 Update from CVS * emacs@sv.gnu.org/emacs--devo--0--patch-668 Update from CVS * emacs@sv.gnu.org/emacs--devo--0--patch-669 Merge from gnus--rel--5.10 * emacs@sv.gnu.org/emacs--devo--0--patch-670 Update from CVS * emacs@sv.gnu.org/emacs--devo--0--patch-671 Update from CVS * emacs@sv.gnu.org/emacs--devo--0--patch-672 Update from CVS * emacs@sv.gnu.org/emacs--devo--0--patch-673 Update from CVS * emacs@sv.gnu.org/gnus--rel--5.10--patch-206 Merge from emacs--devo--0 * emacs@sv.gnu.org/gnus--rel--5.10--patch-207 Merge from emacs--devo--0 * emacs@sv.gnu.org/gnus--rel--5.10--patch-208 Update from CVS git-archimport-id: lorentey@elte.hu--2004/emacs--multi-tty--0--patch-600
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in42
1 files changed, 30 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 01e16fcd12f..874f5c69313 100644
--- a/configure.in
+++ b/configure.in
@@ -54,7 +54,9 @@ AC_DEFINE(MAIL_USE_POP))
AH_TEMPLATE(MAIL_USE_POP, [Define to support POP mail retrieval.])dnl
AC_ARG_WITH(kerberos,
[ --with-kerberos support Kerberos-authenticated POP],
-[AC_DEFINE(KERBEROS)])
+[if test "$withval" = yes; then
+ AC_DEFINE(KERBEROS)
+fi])
AH_TEMPLATE(KERBEROS,
[Define to support Kerberos-authenticated POP mail retrieval.])dnl
AC_ARG_WITH(kerberos5,
@@ -64,11 +66,13 @@ AC_ARG_WITH(kerberos5,
with_kerberos=yes
AC_DEFINE(KERBEROS)
fi
-fi
-AC_DEFINE(KERBEROS5, 1, [Define to use Kerberos 5 instead of Kerberos 4.])])
+ AC_DEFINE(KERBEROS5, 1, [Define to use Kerberos 5 instead of Kerberos 4.])
+fi])
AC_ARG_WITH(hesiod,
[ --with-hesiod support Hesiod to get the POP server host],
-[AC_DEFINE(HESIOD, 1, [Define to support using a Hesiod database to find the POP server.])])
+[if test "$withval" = yes; then
+ AC_DEFINE(HESIOD, 1, [Define to support using a Hesiod database to find the POP server.])
+fi])
AC_ARG_WITH(sound,
[ --without-sound don't compile with sound support])
@@ -279,13 +283,17 @@ dnl see the `changequote' comment above.
opsys=openbsd
case "${canonical}" in
alpha*-*-openbsd*) machine=alpha ;;
- i386-*-openbsd*) machine=intel386 ;;
- x86_64-*-openbsd*) machine=amdx86-64 ;;
- m68k-*-openbsd*) machine=hp9000s300 ;;
- mipsel-*-openbsd*) machine=pmax ;;
- ns32k-*-openbsd*) machine=ns32000 ;;
- sparc-*-openbsd*) machine=sparc ;;
- vax-*-openbsd*) machine=vax ;;
+ arm-*-openbsd*) machine=arm ;;
+ hppa-*-openbsd*) machine=hp9000s300 ;;
+ i386-*-openbsd*) machine=intel386 ;;
+ m68k-*-openbsd*) machine=hp9000s300 ;;
+ m88k-*-openbsd*) machine=aviion ;;
+ mips64-*-openbsd*) machine=mips64 ;;
+ powerpc-*-openbsd*) machine=macppc ;;
+ sh-*-openbsd*) machine=sh3el ;;
+ sparc*-*-openbsd*) machine=sparc ;;
+ vax-*-openbsd*) machine=vax ;;
+ x86_64-*-openbsd*) machine=amdx86-64 ;;
esac
;;
@@ -2123,7 +2131,7 @@ if test "${HAVE_GTK}" = "yes"; then
PKG_CHECK_MODULES(XFT, xft >= 0.13.0, , HAVE_XFT=no)
if test "$HAVE_XFT" != no; then
OLD_CFLAGS="$CPPFLAGS"
- OLD_CFLAGS="$CFLAGS"
+ OLD_CPPFLAGS="$CFLAGS"
OLD_LIBS="$LIBS"
CPPFLAGS="$CPPFLAGS $XFT_CFLAGS"
CFLAGS="$CFLAGS $XFT_CFLAGS"
@@ -3211,6 +3219,16 @@ if test $USE_XASSERTS = yes; then
echo
fi
+if test "$USE_X_TOOLKIT" = GTK; then
+ case "$canonical" in
+ *cygwin*)
+ echo "There are known problems with Emacs and Gtk+ on cygwin, so you
+ will probably get a crash on startup. If this happens, please use another
+ toolkit for Emacs. See etc/PROBLEMS for more information."
+ ;;
+ esac
+fi
+
# Remove any trailing slashes in these variables.