summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2011-03-26 19:27:11 -0700
committerGlenn Morris <rgm@gnu.org>2011-03-26 19:27:11 -0700
commit9af30bdf17f8371664bc0c5854c91c2e46257b5e (patch)
treeef68d0a44cbdc312405a65101dbc5df41316c71a /configure.in
parent7a097943f7d3433a5d053eee4b2f3254230fee64 (diff)
downloademacs-9af30bdf17f8371664bc0c5854c91c2e46257b5e.tar.gz
Remove (RET)SIGTYPE; it is identical to void on all supported systems.
Ref: http://lists.gnu.org/archive/html/emacs-devel/2011-03/msg01068.html * configure.in (AC_TYPE_SIGNAL): Remove obsolete macro. (AH_BOTTOM): Do not define SIGTYPE. * lib-src/emacsclient.c: Replace SIGTYPE with void. * nt/config.nt: Remove RETSIGTYPE, SIGTYPE (identical to void). * src/syssignal.h: Replace RETSIGTYPE with void. * src/atimer.c, src/data.c, src/dispnew.c, src/emacs.c, src/floatfns.c: * src/keyboard.c, src/keyboard.h, src/lisp.h, src/process.c, src/sysdep.c: * src/xterm.c: Replace SIGTYPE with void everywhere. * src/s/template.h (SIGTYPE): Remove commented out definition. * src/s/usg5-4-common.h (SIGTYPE): Remove definition. * admin/CPP-DEFINES: Remove SIGTYPE.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 0 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index fb71b82c464..77deef8dba5 100644
--- a/configure.in
+++ b/configure.in
@@ -1227,9 +1227,6 @@ if test $emacs_cv_struct_utimbuf = yes; then
AC_DEFINE(HAVE_STRUCT_UTIMBUF, 1, [Define to 1 if `struct utimbuf' is declared by <utime.h>.])
fi
-dnl checks for typedefs
-AC_TYPE_SIGNAL
-
dnl Check for speed_t typedef.
AC_CACHE_CHECK(for speed_t, emacs_cv_speed_t,
[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <termios.h>]], [[speed_t x = 1;]])],
@@ -3493,11 +3490,6 @@ AH_BOTTOM([
# define SYSTEM_PURESIZE_EXTRA 30000
#endif
-/* SIGTYPE is the macro we actually use. */
-#ifndef SIGTYPE
-#define SIGTYPE RETSIGTYPE
-#endif
-
#ifdef emacs /* Don't do this for lib-src. */
/* Tell regex.c to use a type compatible with Emacs. */
#define RE_TRANSLATE_TYPE Lisp_Object