summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2011-03-05 17:42:13 -0800
committerGlenn Morris <rgm@gnu.org>2011-03-05 17:42:13 -0800
commit870d9cf691f11eb8ee47d245dd22cbee273c8cde (patch)
tree8307a92208a5b32111868cde01ba3967aa6589ef /configure.in
parent845fc5e555e73449596ba475060fd2674f3b51e9 (diff)
downloademacs-870d9cf691f11eb8ee47d245dd22cbee273c8cde.tar.gz
* configure.in (FREETYPE_LIBS): Actually set it to something.
This was needed for linking a lucid toolkit build on a recent Debian testing system. Without this, it failed with: ftfont.o: undefined reference to symbol 'FT_New_Face'
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 13 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 1f6213211da..69d1a1e5bd3 100644
--- a/configure.in
+++ b/configure.in
@@ -2244,15 +2244,23 @@ if test "${HAVE_X11}" = "yes"; then
fi # "$HAVE_XFT" != no
fi # "x${with_xft}" != "xno"
- dnl For the "Does Emacs use" message at the end.
+ ## We used to allow building with FreeType and without Xft.
+ ## However, the ftx font backend driver is not in good shape.
if test "$HAVE_XFT" != "yes"; then
+ dnl For the "Does Emacs use" message at the end.
HAVE_XFT=no
+ HAVE_FREETYPE=no
+ else
+ dnl Strict linkers fail with
+ dnl ftfont.o: undefined reference to symbol 'FT_New_Face'
+ dnl if -lfreetype is not specified.
+ dnl The following is needed to set FREETYPE_LIBS.
+ PKG_CHECK_MODULES(FREETYPE, freetype2, HAVE_FREETYPE=yes,
+ HAVE_FREETYPE=no)
+
+ test "$HAVE_FREETYPE" = "no" && AC_MSG_ERROR(libxft requires libfreetype)
fi
- ## We used to allow building with FreeType and without Xft.
- ## However, the ftx font backend driver is not in good shape.
- HAVE_FREETYPE=$HAVE_XFT
-
HAVE_LIBOTF=no
if test "${HAVE_FREETYPE}" = "yes"; then
AC_DEFINE(HAVE_FREETYPE, 1,