summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRichard M. Stallman <rms@gnu.org>1995-08-17 17:48:58 +0000
committerRichard M. Stallman <rms@gnu.org>1995-08-17 17:48:58 +0000
commit30457b4f931bb9ee923f6c71ea7b59d109c2e96a (patch)
tree6897ff0087bacce2975161a9bb396c46eeebad76 /configure.in
parent88aabab394936dd4692e0f47aff0cc54f9ded145 (diff)
downloademacs-30457b4f931bb9ee923f6c71ea7b59d109c2e96a.tar.gz
(RANLIB): Substitute this into makefiles.
Set it specially on solaris; set it by default on other systems. Fix previous Alpha change.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 87d9badb71f..ea656331423 100644
--- a/configure.in
+++ b/configure.in
@@ -164,7 +164,7 @@ case "${canonical}" in
machine=alliant-2800 opsys=bsd4-3
;;
- ;; Alpha (DEC) machines.
+ ## Alpha (DEC) machines.
alpha-dec-osf* )
machine=alpha opsys=osf1
;;
@@ -678,10 +678,12 @@ case "${canonical}" in
*-sunos5.4* | *-solaris2.4* )
opsys=sol2-4
NON_GNU_CPP=/usr/ccs/lib/cpp
+ RANLIB="ar -ts"
;;
*-sunos5.5* | *-solaris2.5* )
opsys=sol2-5
NON_GNU_CPP=/usr/ccs/lib/cpp
+ RANLIB="ar -ts"
;;
*-sunos5* | *-solaris* )
opsys=sol2
@@ -826,6 +828,10 @@ if test x"${opsys}" = x; then
esac
fi
+if test "x$RANLIB" = x; then
+ RANLIB=ranlib
+fi
+
changequote([, ])dnl
if test $unported = yes; then
@@ -1338,6 +1344,7 @@ AC_SUBST(CFLAGS)
AC_SUBST(X_TOOLKIT_TYPE)
AC_SUBST(machfile)
AC_SUBST(opsysfile)
+AC_SUBST(RANLIB)
AC_DEFINE_UNQUOTED(EMACS_CONFIGURATION, "${canonical}")
AC_DEFINE_UNQUOTED(EMACS_CONFIG_OPTIONS, "${ac_configure_args}")