summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid J. MacKenzie <djm@gnu.org>1994-11-09 21:09:27 +0000
committerDavid J. MacKenzie <djm@gnu.org>1994-11-09 21:09:27 +0000
commit01345308265171acae1d4f2076a984e27bb9a94f (patch)
treee98b2d92b0bf1e2869e21ff5a9a4f45af443f02e /configure.in
parent535d2617a0c1ae89cd7aad5a871f97470c77eeb8 (diff)
downloademacs-01345308265171acae1d4f2076a984e27bb9a94f.tar.gz
Make h_errno check not use nested functions.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 4 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 5a62a943af9..a9e7b6e8c65 100644
--- a/configure.in
+++ b/configure.in
@@ -1101,14 +1101,10 @@ fi
# If netdb.h doesn't declare h_errno, we must declare it by hand.
AC_MSG_CHECKING(whether netdb declarares h_errno)
AC_TRY_LINK([#include <netdb.h>],
-[int
-foo ()
-{
- return h_errno;
-}
-], [AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_H_ERRNO)],
- [AC_MSG_RESULT(no)])
+ [return h_errno;],
+ [AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_H_ERRNO)],
+ [AC_MSG_RESULT(no)])
AC_FUNC_ALLOCA