summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDan Nicolaescu <dann@ics.uci.edu>2008-08-07 14:21:43 +0000
committerDan Nicolaescu <dann@ics.uci.edu>2008-08-07 14:21:43 +0000
commit48fad8e894ded19e7c207d118cae0dbc0edffe88 (patch)
tree5ffa202f0ab55cdbb858eee6c1e804e2c08571c1 /configure.in
parentbc53d5446c3526d9abad0f4b3d319f2c9adb772d (diff)
downloademacs-48fad8e894ded19e7c207d118cae0dbc0edffe88.tar.gz
* s/darwin.h (OTHER_FILES): Do not define here, defined in
config.in. * Makefile.in (ALL_OBJC_CFLAGS): New variable. (.m.o): Use it. * config.in: Regenerate. * Makefile.in (INSTALLABLES): Add LIB_SRC_EXTRA_INSTALLABLES. Do not special case for NS_IMPL_COCOA. * configure.in (LIB_SRC_EXTRA_INSTALLABLES): New variable. AC_SUBST it. (GNU_OBJC_CFLAGS): Define as a shell variable instead of #define. AC_SUBST it. (OTHER_FILES): Always define for HAVE_NS. (C_SWITCH_X_SYSTEM): Don't define as empty for NS_IMPL_COCOA. * configure: Regenerate.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 8 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 55b3d3d286a..e6b5ea338e2 100644
--- a/configure.in
+++ b/configure.in
@@ -2049,12 +2049,15 @@ if test "${HAVE_NS}" = "yes"; then
AC_DEFINE(HAVE_NS, 1, [Define to 1 if you are using the NeXTstep API, either GNUstep or Cocoa on Mac OS X.])
if test "${NS_IMPL_COCOA}" = "yes"; then
AC_DEFINE(NS_IMPL_COCOA, 1, [Define to 1 if you are using NS windowing under MacOS X.])
+ GNU_OBJC_CFLAGS=
+ LIB_SRC_EXTRA_INSTALLABLES=mac-fix-env
fi
if test "${EN_COCOA_EXPERIMENTAL_CTRL_G}" = "yes"; then
AC_DEFINE(COCOA_EXPERIMENTAL_CTRL_G, 1, [Define to 1 if you are trying experimental enhanced Ctrl-g support using NS windowing under MacOS X.])
fi
if test "${NS_IMPL_GNUSTEP}" = "yes"; then
AC_DEFINE(NS_IMPL_GNUSTEP, 1, [Define to 1 if you are using NS windowing under GNUstep.])
+ GNU_OBJC_CFLAGS="-fgnu-runtime -Wno-import -fconstant-string-class=NSConstantString -DGNUSTEP_BASE_LIBRARY=1 -DGNU_GUI_LIBRARY=1 -DGNU_RUNTIME=1 -DGSWARN -DGSDIAGNOSE"
fi
if test "${NS_HAVE_NSINTEGER}" = "yes"; then
AC_DEFINE(NS_HAVE_NSINTEGER, 1, [Define to 1 if `NSInteger' is defined.])
@@ -2464,6 +2467,8 @@ AC_SUBST(ns_appbindir)
AC_SUBST(ns_appresdir)
AC_SUBST(ns_appsrc)
AC_SUBST(GNUSTEP_MAKEFILES)
+AC_SUBST(GNU_OBJC_CFLAGS)
+AC_SUBST(LIB_SRC_EXTRA_INSTALLABLES)
AC_DEFINE_UNQUOTED(EMACS_CONFIGURATION, "${canonical}",
[Define to the canonical Emacs configuration name.])
@@ -2607,18 +2612,14 @@ AH_BOTTOM([
side does this in s/darwin.h and we cannot
parallel this exactly since GNUstep is multi-OS. */
#ifdef HAVE_NS
+#define OTHER_FILES ns-app
# ifdef NS_IMPL_GNUSTEP
/* See also .m.o rule in Makefile.in */
# define C_SWITCH_X_SYSTEM -D_REENTRANT -fPIC -fno-strict-aliasing
-# define GNU_OBJC_CFLAGS -fgnu-runtime -Wno-import -fconstant-string-class=NSConstantString -DGNUSTEP_BASE_LIBRARY=1 -DGNU_GUI_LIBRARY=1 -DGNU_RUNTIME=1 -DGSWARN -DGSDIAGNOSE
-# define OTHER_FILES ns-app
-# else /* NS_IMPL_COCOA */
-# define C_SWITCH_X_SYSTEM
-# define GNU_OBJC_CFLAGS
-# endif /* NS_IMPL_COCOA */
+# endif /* NS_IMPL_GNUSTEP */
#endif /* HAVE_NS */
-/* Define `subprocesses' should be defined if you want to
+/* `subprocesses' should be defined if you want to
have code for asynchronous subprocesses
(as used in M-x compile and M-x shell).
Only MSDOS does not support this. */