summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKen Raeburn <raeburn@raeburn.org>2001-10-24 22:54:38 +0000
committerKen Raeburn <raeburn@raeburn.org>2001-10-24 22:54:38 +0000
commit84e70f78690c02e12704751941824325920923ea (patch)
tree354d71352b7c7b31cec7cf574dd5c2ebdc907113 /configure.in
parent7d8177cf90333a55b126757e931ae0f5c9db35f6 (diff)
downloademacs-84e70f78690c02e12704751941824325920923ea.tar.gz
fix build problems with krb5 and hesiod support
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fcfd53e18c8..ac88c87478f 100644
--- a/configure.in
+++ b/configure.in
@@ -1962,6 +1962,23 @@ AC_CHECK_FUNCS(getpt)
# than to expect to find it in ncurses.
AC_CHECK_LIB(ncurses, tparm)
+# Do we need the Hesiod library to provide the support routines?
+if test "$with_hesiod" = yes ; then
+ # Don't set $LIBS here -- see comments above.
+ resolv=no
+ AC_CHECK_FUNC(res_send, , [AC_CHECK_FUNC(__res_send, ,
+ [AC_CHECK_LIB(resolv, res_send, resolv=yes,
+ [AC_CHECK_LIB(resolv, __res_send, resolv=yes)])])])
+ if test "$resolv" = yes ; then
+ RESOLVLIB=-lresolv
+ AC_DEFINE(HAVE_LIBRESOLV)
+ else
+ RESOLVLIB=
+ fi
+ AC_CHECK_FUNC(hes_getmailhost, , [AC_CHECK_LIB(hesiod, hes_getmailhost,
+ AC_DEFINE(HAVE_LIBHESIOD), :, $RESOLVLIB)])
+fi
+
# These tell us which Kerberos-related libraries to use.
if test "${with_kerberos+set}" = set; then
AC_CHECK_LIB(com_err, com_err)