summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGerd Moellmann <gerd@gnu.org>2001-11-29 12:06:35 +0000
committerGerd Moellmann <gerd@gnu.org>2001-11-29 12:06:35 +0000
commitba45dae077ec05252b96aaaf184741cab8b3d34d (patch)
treefb2c545495f19d2e70764e9e33033172a42d3cf3 /configure.in
parent140cc574b80e22a7e6866b00a77f913eefef9191 (diff)
downloademacs-ba45dae077ec05252b96aaaf184741cab8b3d34d.tar.gz
Add support for FreeBSD/Alpha.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 0b8265cc276..7af34fb142e 100644
--- a/configure.in
+++ b/configure.in
@@ -183,6 +183,15 @@ changequote(, )dnl
machine='' opsys='' unported=no
case "${canonical}" in
+ ## FreeBSD ports
+ *-*-freebsd* )
+ opsys=freebsd
+ case "${canonical}" in
+ alpha*-*-freebsd*) machine=alpha ;;
+ i[3456]86-*-freebsd*) machine=intel386 ;;
+ esac
+ ;;
+
## NetBSD ports
*-*-netbsd* )
opsys=netbsd
@@ -1027,7 +1036,6 @@ case "${canonical}" in
;;
*-sysv4.2uw* ) opsys=unixware; NON_GNU_CPP=/lib/cpp ;;
*-386bsd* ) opsys=386bsd ;;
- *-freebsd* ) opsys=freebsd ;;
*-nextstep* ) opsys=nextstep ;;
## Otherwise, we'll fall through to the generic opsys code at the bottom.
esac