summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndreas Schwab <schwab@linux-m68k.org>2010-12-10 23:42:17 +0100
committerAndreas Schwab <schwab@linux-m68k.org>2010-12-10 23:42:17 +0100
commit2b7f50d8775c7236b947c2f3e78786c1e2002722 (patch)
treeab82b063c66cfc01cc953224e25dfbe46d933431 /configure.in
parent175069efeb080517afefdd44a06f7a779ea8c25c (diff)
downloademacs-2b7f50d8775c7236b947c2f3e78786c1e2002722.tar.gz
Don't depend on POSIX compatible parsing of parameter expansion
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index ed071b83475..dbced95093e 100644
--- a/configure.in
+++ b/configure.in
@@ -3638,12 +3638,17 @@ if test "${HAVE_GTK}" = "yes"; then
USE_X_TOOLKIT=GTK
fi
+and_machfile=
+if test -n "$machfile"; then
+ and_machfile=" and \`${machfile}'"
+fi
+
echo "
Configured for \`${canonical}'.
Where should the build process find the source code? ${srcdir}
What operating system and machine description files should Emacs use?
- \`${opsysfile}'${machfile:+ and \`${machfile}'}
+ \`${opsysfile}'${and_machfile}
What compiler should emacs be built with? ${CC} ${CFLAGS}
Should Emacs use the GNU version of malloc? ${GNU_MALLOC}${GNU_MALLOC_reason}
Should Emacs use a relocating allocator for buffers? ${REL_ALLOC}