summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2011-10-19 23:52:55 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2011-10-19 23:52:55 -0700
commit7da0b018f2878484a68031800877f98872356594 (patch)
treeea100eba53f6ab263b7d5bb5094c7562208fbf9d /configure.in
parent07fc67afe373b19c3365f9ed530cda48281da81a (diff)
downloademacs-7da0b018f2878484a68031800877f98872356594.tar.gz
Time zone name fixes for non-ASCII locales (Bug#641, Bug#9794)
* configure.in (AC_STRUCT_TM, AC_STRUCT_TIMEZONE, HAVE_TM_GMTOFF): Remove; no longer needed, now that we defer to strftime for time zone names. * src/editfns.c: Rewrite current-time-zone so that it invokes the equivalent of (format-time-string "%Z") to get the time zone name. This fixes a bug when the time zone name contains characters that need converting from the system time locale to Emacs internal format. This fixes a shortcoming that I introduced in my 1999-10-19 patch: that patch fixed format-time-string to do the conversion, but I forgot to fix current-time-zone. (format_time_string): New function, containing most of what Fformat_time_string used to contain. (Fformat_time_string): Rewrite in terms of format_time_string. This doesn't change this function's behavior. (current-time-zone): Rewrite to use format_time_string. This fixes the bug reported by Michael Schierl in <http://lists.gnu.org/archive/html/emacs-devel/2007-06/msg00334.html>. Jason Rumney's 2007-06-07 change worked around this bug, but didn't fix it. * src/systime.h (tzname, timezone): Remove no-longer-used declarations.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 4a5788600c8..5b32e10853f 100644
--- a/configure.in
+++ b/configure.in
@@ -1315,12 +1315,6 @@ AC_CHECK_HEADERS(net/if_dl.h, , , [AC_INCLUDES_DEFAULT
AC_CHECK_FUNCS(getifaddrs freeifaddrs)
dnl checks for structure members
-AC_STRUCT_TM
-AC_STRUCT_TIMEZONE
-AC_CHECK_MEMBER(struct tm.tm_gmtoff,
- [AC_DEFINE(HAVE_TM_GMTOFF, 1,
- [Define to 1 if `tm_gmtoff' is member of `struct tm'.])],,
- [#include <time.h>])
AC_CHECK_MEMBERS([struct ifreq.ifr_flags, struct ifreq.ifr_hwaddr,
struct ifreq.ifr_netmask, struct ifreq.ifr_broadaddr,
struct ifreq.ifr_addr,