summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2011-05-23 21:00:56 -0700
committerGlenn Morris <rgm@gnu.org>2011-05-23 21:00:56 -0700
commit6c7e099d060749c70637672abac18131833d3cc1 (patch)
tree705a4404bb2a160884d72c69f9758d4df9c6bb8d /configure.in
parentdb0406bb64f7e5dceeb257c7e350f1e80ed9c1c1 (diff)
downloademacs-6c7e099d060749c70637672abac18131833d3cc1.tar.gz
Restore test/ to its non-distributed state (bug#8107)
* make-dist: Don't distribute test/. * configure.in (OPT_MAKEFILES_IN): New output variable. (AC_CONFIG_FILES): Conditionally include test/automated/Makefile. * Makefile.in (OPT_MAKEFILES_IN): New, set by configure. (SUBDIR_MAKEFILES_IN): Use $OPT_MAKEFILES_IN. (check): Give an explicit error if test/ is not present.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index dd895f3f06f..c06965ca17d 100644
--- a/configure.in
+++ b/configure.in
@@ -3715,7 +3715,16 @@ test "${exec_prefix}" != NONE &&
AC_CONFIG_FILES([Makefile lib/Makefile lib-src/Makefile oldXMenu/Makefile \
doc/emacs/Makefile doc/misc/Makefile doc/lispintro/Makefile \
doc/lispref/Makefile src/Makefile \
- lwlib/Makefile lisp/Makefile leim/Makefile test/automated/Makefile])
+ lwlib/Makefile lisp/Makefile leim/Makefile])
+
+dnl test/ is not present in release tarfiles.
+if test -f $srcdir/test/automated/Makefile.in; then
+ OPT_MAKEFILES_IN=test/automated/Makefile.in
+ AC_CONFIG_FILES([test/automated/Makefile])
+else
+ OPT_MAKEFILES_IN=
+fi
+AC_SUBST(OPT_MAKEFILES_IN)
dnl Make the necessary directories, if they don't exist.
AC_CONFIG_COMMANDS([mkdirs], [