summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGerd Moellmann <gerd@gnu.org>2000-09-06 21:23:55 +0000
committerGerd Moellmann <gerd@gnu.org>2000-09-06 21:23:55 +0000
commitb1b4ce06bb678b51d9a16ce3d287748225c19484 (patch)
tree0490459ac69202d52efb9d56ef9d40c66a81ce78 /configure.in
parentfa0b693ce2fa8b1e5888e1becc774b875b95c414 (diff)
downloademacs-b1b4ce06bb678b51d9a16ce3d287748225c19484.tar.gz
(REL_ALLOC_MMAP): Recognize in system configuration
file and print informational message.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 17 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 7806a1e4026..c28ec390971 100644
--- a/configure.in
+++ b/configure.in
@@ -1228,6 +1228,12 @@ configure___ system_malloc=yes
configure___ system_malloc=no
#endif
+#ifdef REL_ALLOC_MMAP
+configure___ rel_alloc_mmap=yes
+#else
+configure___ rel_alloc_mmap=no
+#endif
+
#ifndef C_DEBUG_SWITCH
#define C_DEBUG_SWITCH -g
#endif
@@ -1538,6 +1544,15 @@ if test x"${REL_ALLOC}" = x; then
REL_ALLOC=${GNU_MALLOC}
fi
+@dnl For now, need to use an explicit `#define REL_ALLOC_MMAP 1' in
+@dnl the system configuration file (s/*.h) to turn the use of mmap
+@dnl in the relocating allocator on.
+
+AC_FUNC_MMAP
+if test $rel_alloc_mmap = yes; then
+ REL_ALLOC=yes
+fi
+
LIBS="$libsrc_libs $LIBS"
dnl If found, this defines HAVE_LIBDNET, which m/pmax.h checks,
@@ -2089,7 +2104,6 @@ else
fi
AC_FUNC_VFORK
-AC_FUNC_MMAP
# Fixme: This should be replaced when we have autoconf 2.14.
AC_SIZE_T
@@ -2180,7 +2194,8 @@ Configured for \`${canonical}'.
\`${opsysfile}' and \`${machfile}'
What compiler should emacs be built with? ${CC} ${CFLAGS}
Should Emacs use the GNU version of malloc? ${GNU_MALLOC}${GNU_MALLOC_reason}
- Should Emacs use the relocating allocator for buffers? ${REL_ALLOC}
+ Should Emacs use a relocating allocator for buffers? ${REL_ALLOC}
+ Should Emacs use mmap for the relocating allocator? $rel_alloc_mmap
What window system should Emacs use? ${window_system}
What toolkit should Emacs use? ${USE_X_TOOLKIT}"