summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJuanma Barranquero <lekktu@gmail.com>2003-06-02 19:26:18 +0000
committerJuanma Barranquero <lekktu@gmail.com>2003-06-02 19:26:18 +0000
commitefd60266f5c1719715230627d61339a6e40ef442 (patch)
treed857237fc52b74df04f6ae3bb9322ecee5d9c9a3 /configure.in
parent5b07197ad97cfdac6af695fac3a5efbf8f8c122a (diff)
downloademacs-efd60266f5c1719715230627d61339a6e40ef442.tar.gz
Revert changes of 2003-03-03 and 2003-05-28.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 9 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index ab08f35dabe..a4eb85b220f 100644
--- a/configure.in
+++ b/configure.in
@@ -2854,20 +2854,15 @@ typedef unsigned size_t;
# endif
#endif
-/* On Mac OS X, these macros are already defined in precompiled headers. */
-#ifndef MAC_OSX
-/* avoid deprecated functions */
-# ifdef HAVE_MEMCPY
-# define bcopy(a,b,s) memcpy (b,a,s)
-# endif
-# ifdef HAVE_MEMSET
-# define bzero(a,s) memset (a,0,s)
-# endif
-# ifdef HAVE_MEMCMP
-# define BCMP memcmp
-# define bcmp memcmp
-# endif
-#endif /* MAC_OSX */
+#ifndef HAVE_BCOPY
+#define bcopy(a,b,s) memcpy (b,a,s)
+#endif
+#ifndef HAVE_BZERO
+#define bzero(a,s) memset (a,0,s)
+#endif
+#ifndef HAVE_BCMP
+#define BCMP memcmp
+#endif
#endif /* EMACS_CONFIG_H */