summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKen Raeburn <raeburn@raeburn.org>2000-02-17 20:04:15 +0000
committerKen Raeburn <raeburn@raeburn.org>2000-02-17 20:04:15 +0000
commit3b3cc4a4899022e6f12bd9cfdbb854111f8443e6 (patch)
tree215f380fc80789dc7e8489bb11ec75f3604927fa /configure.in
parente3d4de904d1cea029c3321c435441d708c5316d9 (diff)
downloademacs-3b3cc4a4899022e6f12bd9cfdbb854111f8443e6.tar.gz
include -lz and -ljpeg when testing for -ltiff
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 81393e1145c..2c999c2ce5f 100644
--- a/configure.in
+++ b/configure.in
@@ -1740,7 +1740,10 @@ if test "${HAVE_X11}" = "yes"; then
old_c_flags="${CFLAGS}"
CFLAGS="${LD_SWITCH_X_SITE} ${CFLAGS}"
AC_CHECK_HEADER(tiffio.h,
- AC_CHECK_LIB(tiff, TIFFGetVersion, HAVE_TIFF=yes, , -lX11 -lm))
+ tifflibs="-lX11 -lz -lm"
+ # At least one tiff package requires the jpeg library.
+ if test "${HAVE_JPEG}" = yes; then tifflibs="-ljpeg $tifflibs"; fi
+ AC_CHECK_LIB(tiff, TIFFGetVersion, HAVE_TIFF=yes, , $tifflibs))
CFLAGS="${old_c_flags}"
fi