summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStefan Monnier <monnier@iro.umontreal.ca>2004-01-27 16:48:17 +0000
committerStefan Monnier <monnier@iro.umontreal.ca>2004-01-27 16:48:17 +0000
commit22bb9485c84244486df39446201c54b9d82373d8 (patch)
tree2dd286a29feac869c37d410314e79839ab012272 /configure.in
parenteb37b8fd092e4607705f11ee2f9abd9491ecac5a (diff)
downloademacs-22bb9485c84244486df39446201c54b9d82373d8.tar.gz
<darwin>: Use fink packages if available.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8663ce9765c..d5e4ba1e69b 100644
--- a/configure.in
+++ b/configure.in
@@ -1135,6 +1135,12 @@ dnl see the `changequote' comment above.
machine=powermac opsys=darwin
# Define CPP as follows to make autoconf work correctly.
CPP="${CC-cc} -E -no-cpp-precomp"
+ # Use fink packages if available.
+ if test -d /sw/include && test -d /sw/lib; then
+ GCC_TEST_OPTIONS="-I/sw/include -L/sw/lib"
+ CPP="${CPP} ${GCC_TEST_OPTIONS}"
+ NON_GCC_TEST_OPTIONS=${GCC_TEST_OPTIONS}
+ fi
;;
## AMD x86-64 Linux-based GNU system