summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChong Yidong <cyd@stupidchicken.com>2008-08-04 21:57:15 +0000
committerChong Yidong <cyd@stupidchicken.com>2008-08-04 21:57:15 +0000
commitb5a75fe7fb371007373216c9be40964494ab58ef (patch)
tree93ee3e8d39dcb69a5c6f5886d5608473f868c794 /configure.in
parent62b805bafae0c9b9d8e37e0050fe81d2ce321295 (diff)
downloademacs-b5a75fe7fb371007373216c9be40964494ab58ef.tar.gz
Test for existence of NSInteger.
Suggested by Yavor Doganov.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7910af3b4a0..283b290ab82 100644
--- a/configure.in
+++ b/configure.in
@@ -1236,6 +1236,14 @@ if test "${with_ns}" != no; then
LDFLAGS="$LDFLAGS -L${GNUSTEP_SYSTEM_LIBRARIES}"
fi
AC_CHECK_HEADER(AppKit/AppKit.h, HAVE_NS=yes)
+ NS_HAVE_INTEGER=yes
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([#include <Foundation/NSObjCRuntime.h>],
+ [NSInteger i;])],
+ ns_have_integer=yes,
+ ns_have_integer=no)
+ if test $ns_have_integer = no; then
+ NS_HAVE_INTEGER=no
+ fi
fi
if test "${HAVE_NS}" = yes; then
window_system=nextstep
@@ -2046,6 +2054,9 @@ if test "${HAVE_NS}" = "yes"; then
if test "${NS_IMPL_GNUSTEP}" = "yes"; then
AC_DEFINE(NS_IMPL_GNUSTEP, 1, [Define to 1 if you are using NS windowing under GNUstep.])
fi
+ dnl if test "${NS_HAVE_INTEGER}" = "yes"; then
+ AC_DEFINE(NS_HAVE_INTEGER, 1, [Define to 1 if `NSInteger' is defined.])
+ dnl fi
# We also have mouse menus.
HAVE_MENUS=yes
fi