summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDan Nicolaescu <dann@ics.uci.edu>2008-06-26 04:24:54 +0000
committerDan Nicolaescu <dann@ics.uci.edu>2008-06-26 04:24:54 +0000
commit4218a3c5d365c89f493cf41845bcab20dc18d3a7 (patch)
tree0964588a634febc5127595c7db6798451c412534 /configure.in
parentb6ab0b68078cbf72506a5818d7b154d7373de2e3 (diff)
downloademacs-4218a3c5d365c89f493cf41845bcab20dc18d3a7.tar.gz
* unexnext.c:
* m/ews4800.h: * m/hp9000s300.h: * m/ibm370aix.h: * m/mips-siemens.h: * m/ncr386.h: * m/next.h: * m/pmax.h: * m/powerpcle.h: * m/tandem-s2.h: * s/386bsd.h: * s/bsd386.h: * s/bsd4-1.h: * s/bsd4-2.h: * s/bsdos2-1.h: * s/bsdos2.h: * s/bsdos3.h: * s/bsdos4.h: * s/nextstep.h: * s/ultrix4-3.h: * s/usg5-0.h: * s/usg5-2-2.h: * s/usg5-2.h: * s/usg5-4-3.h: * s/ux4800.h: * s/uxpds.h: * s/uxpv.h: Remove support for obsolete systems. * s/hpux.h, s/hpux10.h, s/hpux8.h, s/hpux9.h, s/hpux9shr.h: Remove, insert contents in s/hpux-10.20.h * s/aix3-1.h, s/aix3-2-5.h, s/aix3-2.h, s/aix4-1.h, s/aix4.h: Remove, insert contents in s/aix-4.2.h * s/usg5-3.h: Remove, insert contents in s/usg5-4.h. * s/bsd4-3.h: Rename to .. * s/bsd-common.h: ... this. * src/data.c: * src/doc.c: * src/ecrt0.c: * src/emacs.c: * src/fileio.c: * src/floatfns.c: * src/keyboard.c: * src/mem-limits.h: * src/print.c: * src/process.c: * src/sysdep.c: * src/syssignal.h: * src/systty.h: * src/syswait.h: * src/term.c: * src/unexec.c: * src/unexelf.c: * src/unexhp9k800.c: * src/m/hp800.h: * src/m/ibmrs6000.h: * src/m/mips.h: * src/m/vax.h: * src/s/darwin.h: * src/s/freebsd.h: * src/s/gnu.h: * src/s/ms-w32.h: * src/s/msdos.h: * src/s/netbsd.h: * src/s/template.h: Remove references to obsolete variables. * Makefile.in: Add dependencies for all unexec files. (admindir): Remove unused variable. (UNEXEC_SRC): Remove references. * config.nt: Remove reference to UNEXEC_SRC. * lwlib.c: Remove references to obsolete variables. * fakemail.c: Remove references to obsolete variables. * os.texi: Remove references to obsolete systems. * configure.in: * configure: Remove references to obsolete systems.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in215
1 files changed, 2 insertions, 213 deletions
diff --git a/configure.in b/configure.in
index 7e90aa68cbf..72982ad80d3 100644
--- a/configure.in
+++ b/configure.in
@@ -265,9 +265,8 @@ dnl quotation begins
### based on the machine portion of the configuration name, and an s-
### file based on the operating system portion. However, it turns out
### that each m/*.h file is pretty manufacturer-specific - for
-### example hp9000s300.h is a 68000 machine;
-### mips.h, pmax.h are all MIPS
-### machines. So we basically have to have a special case for each
+### example mips.h is MIPS
+### So we basically have to have a special case for each
### configuration name.
###
### As far as handling version numbers on operating systems is
@@ -322,12 +321,6 @@ dnl see the `changequote' comment above.
case "${canonical}" in
alpha*-*-netbsd*) machine=alpha ;;
i[3456]86-*-netbsd*) machine=intel386 ;;
- m68k-*-netbsd*)
- # This is somewhat bogus.
- machine=hp9000s300 ;;
- mips-*-netbsd*) machine=pmax ;;
- mipsel-*-netbsd*) machine=pmax ;;
- mipseb-*-netbsd*) machine=pmax ;;
powerpc-*-netbsd*) machine=macppc ;;
sparc*-*-netbsd*) machine=sparc ;;
vax-*-netbsd*) machine=vax ;;
@@ -343,9 +336,7 @@ dnl see the `changequote' comment above.
case "${canonical}" in
alpha*-*-openbsd*) machine=alpha ;;
arm-*-openbsd*) machine=arm ;;
- hppa-*-openbsd*) machine=hp9000s300 ;;
i386-*-openbsd*) machine=intel386 ;;
- m68k-*-openbsd*) machine=hp9000s300 ;;
powerpc-*-openbsd*) machine=macppc ;;
sparc*-*-openbsd*) machine=sparc ;;
vax-*-openbsd*) machine=vax ;;
@@ -362,23 +353,6 @@ dnl see the `changequote' comment above.
esac
;;
- ## BSDI ports
- *-*-bsdi* )
- opsys=bsdi
- case "${canonical}" in
- i[345]86-*-bsdi*) machine=intel386 ;;
- sparc-*-bsdi*) machine=sparc ;;
- powerpc-*-bsdi*) machine=macppc ;;
- esac
- case "${canonical}" in
- *-*-bsd386* | *-*-bsdi1* ) opsys=bsd386 ;;
- *-*-bsdi2.0* ) opsys=bsdos2 ;;
- *-*-bsdi2* ) opsys=bsdos2-1 ;;
- *-*-bsdi3* ) opsys=bsdos3 ;;
- *-*-bsdi[45]* ) opsys=bsdos4 ;;
- esac
- ;;
-
alpha*-*-linux-gnu* )
machine=alpha opsys=gnu-linux
;;
@@ -405,56 +379,10 @@ dnl see the `changequote' comment above.
fi
;;
- ## Cubix QBx/386
- i[3456]86-cubix-sysv* )
- machine=intel386 opsys=usg5-3
- ;;
-
- mips-dec-ultrix[0-3].* | mips-dec-ultrix4.0* | mips-dec-bsd4.2* )
- machine=pmax opsys=bsd4-2
- ;;
- mips-dec-ultrix4.[12]* | mips-dec-bsd* )
- machine=pmax opsys=bsd4-3
- ;;
- mips-dec-ultrix* )
- machine=pmax opsys=ultrix4-3
- ;;
- ## HP 9000 series 200 or 300
- m68*-hp-bsd* )
- machine=hp9000s300 opsys=bsd4-3
- ;;
- ## HP/UX 7, 8, 9, and 10 are supported on these machines.
- m68*-hp-hpux* )
- case "`uname -r`" in
- ## Someone's system reports A.B8.05 for this.
- ## I wonder what other possibilities there are.
- *.B8.* ) machine=hp9000s300 opsys=hpux8 ;;
- *.08.* ) machine=hp9000s300 opsys=hpux8 ;;
- *.09.* ) machine=hp9000s300 opsys=hpux9 ;;
- *.1[0-9].* ) machine=hp9000s300 opsys=hpux9shr ;;
- *) machine=hp9000s300 opsys=hpux ;;
- esac
- ;;
-
## HP 9000 series 700 and 800, running HP/UX
- hppa*-hp-hpux7* )
- machine=hp800 opsys=hpux
- ;;
- hppa*-hp-hpux8* )
- machine=hp800 opsys=hpux8
- ;;
- hppa*-hp-hpux9shr* )
- machine=hp800 opsys=hpux9shr
- ;;
- hppa*-hp-hpux9* )
- machine=hp800 opsys=hpux9
- ;;
hppa*-hp-hpux10.2* )
machine=hp800 opsys=hpux10-20
;;
- hppa*-hp-hpux10* )
- machine=hp800 opsys=hpux10
- ;;
hppa*-hp-hpux1[1-9]* )
machine=hp800 opsys=hpux11
CFLAGS="-D_INCLUDE__STDC_A1_SOURCE $CFLAGS"
@@ -464,41 +392,13 @@ dnl see the `changequote' comment above.
machine=hp800 opsys=gnu-linux
;;
- ## HP 9000 series 700 and 800, running HP/UX
- hppa*-hp-hpux* )
- ## Cross-compilation? Nah!
- case "`uname -r`" in
- ## Someone's system reports A.B8.05 for this.
- ## I wonder what other possibilities there are.
- *.B8.* ) machine=hp800 opsys=hpux8 ;;
- *.08.* ) machine=hp800 opsys=hpux8 ;;
- *.09.* ) machine=hp800 opsys=hpux9 ;;
- *) machine=hp800 opsys=hpux10 ;;
- esac
- ;;
- hppa*-*-nextstep* )
- machine=hp800 opsys=nextstep
- ;;
-
## IBM machines
- i370-ibm-aix*)
- machine=ibm370aix opsys=usg5-3
- ;;
s390-*-linux-gnu* )
machine=ibms390 opsys=gnu-linux
;;
s390x-*-linux-gnu* )
machine=ibms390x opsys=gnu-linux
;;
- rs6000-ibm-aix3.1* | powerpc-ibm-aix3.1* )
- machine=ibmrs6000 opsys=aix3-1
- ;;
- rs6000-ibm-aix3.2.5 | powerpc-ibm-aix3.2.5 )
- machine=ibmrs6000 opsys=aix3-2-5
- ;;
- rs6000-ibm-aix4.1* | powerpc-ibm-aix4.1* )
- machine=ibmrs6000 opsys=aix4-1
- ;;
rs6000-ibm-aix4.2* | powerpc-ibm-aix4.2* )
machine=ibmrs6000 opsys=aix4-2
;;
@@ -511,65 +411,12 @@ dnl see the `changequote' comment above.
rs6000-ibm-aix5* | powerpc-ibm-aix6* )
machine=ibmrs6000 opsys=aix4-2
;;
- rs6000-ibm-aix4.0* | powerpc-ibm-aix4.0* )
- machine=ibmrs6000 opsys=aix4
- ;;
- rs6000-ibm-aix4* | powerpc-ibm-aix4* )
- machine=ibmrs6000 opsys=aix4-1
- ;;
- rs6000-ibm-aix* | powerpc-ibm-aix* )
- machine=ibmrs6000 opsys=aix3-2
- ;;
-
- ## Prime EXL
- i[3456]86-prime-sysv* )
- machine=i386 opsys=usg5-3
- ;;
-
- ## ncr machine running svr4.3.
- i[3456]86-ncr-sysv4.3 )
- machine=ncr386 opsys=usg5-4-3
- ;;
-
- ## Unspecified sysv on an ncr machine defaults to svr4.2.
- ## (Plain usg5-4 doesn't turn on POSIX signals, which we need.)
- i[3456]86-ncr-sysv* )
- machine=ncr386 opsys=usg5-4-2
- ;;
## Macintosh PowerPC
powerpc*-*-linux-gnu* )
machine=macppc opsys=gnu-linux
;;
- ## Workstations sold by MIPS
- ## This is not necessarily all workstations using the MIPS processor -
- ## Irises are produced by SGI, and DECstations by DEC.
-
- mips-mips-bsd* )
- machine=mips opsys=bsd4-3
- ;;
- mips-mips-* )
- machine=mips opsys=usg5-2-2
- ;;
-
- ## NeXT
- m68*-next-* | m68k-*-nextstep* )
- machine=m68k opsys=nextstep
- ;;
-
- ## NEC EWS4800
- mips-nec-sysv4*)
- machine=ews4800 opsys=ux4800
- ;;
-
- ## Siemens Nixdorf
- mips-siemens-sysv* | mips-sni-sysv*)
- machine=mips-siemens opsys=usg5-4
- NON_GNU_CC=/usr/ccs/bin/cc
- NON_GNU_CPP=/usr/ccs/lib/cpp
- ;;
-
## Silicon Graphics machines
## Iris 4D
mips-sgi-irix6.5 )
@@ -592,7 +439,6 @@ dnl see the `changequote' comment above.
case "${canonical}" in
i[3456]86-*-* ) machine=intel386 ;;
amd64-*-*|x86_64-*-*) machine=amdx86-64 ;;
- powerpcle* ) machine=powerpcle ;;
powerpc* | rs6000* ) machine=ibmrs6000 ;;
sparc* ) machine=sparc ;;
* ) unported=yes ;;
@@ -622,7 +468,6 @@ dnl see the `changequote' comment above.
emacs_check_sunpro_c=yes
NON_GNU_CPP=/usr/ccs/lib/cpp
;;
- * ) opsys=bsd4-2 ;;
esac
## Watch out for a compiler that we know will not work.
case "${canonical}" in
@@ -636,24 +481,11 @@ dnl see the `changequote' comment above.
*) ;;
esac
;;
- sparc-*-nextstep* )
- machine=sparc opsys=nextstep
- ;;
-
- ## Tandem Integrity S2
- mips-tandem-sysv* )
- machine=tandem-s2 opsys=usg5-3
- ;;
## Vaxen.
vax-dec-* )
machine=vax
case "${canonical}" in
- *-bsd4.1* ) opsys=bsd4-1 ;;
- *-bsd4.2* | *-ultrix[0-3].* | *-ultrix4.0* ) opsys=bsd4-2 ;;
- *-bsd4.3* | *-ultrix* ) opsys=bsd4-3 ;;
- *-sysv[01]* | *-sysvr[01]* ) opsys=usg5-0 ;;
- *-sysv2* | *-sysvr2* ) opsys=usg5-2 ;;
*-vms* ) opsys=vms ;;
* ) unported=yes
esac
@@ -676,8 +508,6 @@ dnl see the `changequote' comment above.
*-sysv4.2uw* ) opsys=unixware; NON_GNU_CPP=/lib/cpp ;;
*-sysv5uw* ) opsys=unixware; NON_GNU_CPP=/lib/cpp ;;
*-sysv5OpenUNIX* ) opsys=unixware; NON_GNU_CPP=/lib/cpp ;;
- *-386bsd* ) opsys=386bsd ;;
- *-nextstep* ) opsys=nextstep ;;
## Otherwise, we'll fall through to the generic opsys code at the bottom.
esac
;;
@@ -692,13 +522,6 @@ dnl see the `changequote' comment above.
machine=mips opsys=gnu-linux
;;
- ## UXP/DS
- sparc-fujitsu-sysv4* )
- machine=sparc opsys=uxpds
- NON_GNU_CPP=/usr/ccs/lib/cpp
- RANLIB="ar -ts"
- ;;
-
## AMD x86-64 Linux-based GNU system
x86_64-*-linux-gnu* )
machine=amdx86-64 opsys=gnu-linux
@@ -723,13 +546,6 @@ esac
if test x"${opsys}" = x; then
case "${canonical}" in
*-gnu* ) opsys=gnu ;;
- *-bsd4.[01] ) opsys=bsd4-1 ;;
- *-bsd4.2 ) opsys=bsd4-2 ;;
- *-bsd4.3 ) opsys=bsd4-3 ;;
- *-sysv0 | *-sysvr0 ) opsys=usg5-0 ;;
- *-sysv2 | *-sysvr2 ) opsys=usg5-2 ;;
- *-sysv2.2 | *-sysvr2.2 ) opsys=usg5-2-2 ;;
- *-sysv3* | *-sysvr3* ) opsys=usg5-3 ;;
*-sysv4.2uw* ) opsys=unixware ;;
*-sysv5uw* ) opsys=unixware ;;
*-sysv5OpenUNIX* ) opsys=unixware ;;
@@ -752,30 +568,6 @@ if test x"${opsys}" = x; then
esac
fi
-### Tests for sytems that we beleive are obsolete and should be desupported.
-
-case "${machine}" in
- pmax | hp9000s300 | ibm370aix | ncr386 | ews4800 | mips-siemens | powerpcle | tandem-s2 )
- echo "The system that you are configuring on: ${canonical} is considered to be obsolete"
- echo "and it is planned to be desupported in the next version of Emacs"
- echo "Please email emacs-devel@gnu.org as soon as possible if this system is still in use."
- echo "The code is still functional, but you need to edit the 'configure' script and remove the"
- echo "exit 33 line. After that you can run configure again and 'complete' the build."
- exit 33
- ;;
-esac
-
-case "${opsys}" in
- bsd386 | bsdos2-1 | bsdos2 | bsdos3 | bsdos4 | bsd4-1 | bsd4-2 | bsd4-3 | usg5-0 | usg5-2-2 | usg5-2 | usg5-3 | ultrix4-3 | 386bsd | hpux | hpux8 | hpux9 | hpux9shr | hpux10 | aix3-1 | aix3-2-5 | aix3-2 | aix4-1 | nextstep | ux4800 | uxpds | uxpv )
- echo "The system that you are configuring on: ${canonical} is considered to be obsolete"
- echo "and it is planned to be desupported in the next version of Emacs"
- echo "Please email emacs-devel@gnu.org as soon as possible if this system is still in use."
- echo "The code is still functional, but you need to edit the 'configure' script and remove the"
- echo "'exit 44' line. After that you can run 'configure' again and complete the build."
- exit 44
- ;;
-esac
-
]
dnl quotation ends
@@ -1475,9 +1267,6 @@ case ${HAVE_X11} in
yes ) HAVE_MENUS=yes ;;
esac
-### Compute the unexec source name from the object name.
-UNEXEC_SRC="`echo ${unexec} | sed 's/\.o/.c/'`"
-
# Do the opsystem or machine files prohibit the use of the GNU malloc?
# Assume not, until told otherwise.
GNU_MALLOC=yes