summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2011-06-28 20:47:07 -0700
committerGlenn Morris <rgm@gnu.org>2011-06-28 20:47:07 -0700
commite9dfbb4a2cc9fd0b5a542114803a60732a375599 (patch)
tree583d322199da5238745af3696812bbd3c25379e5 /configure.in
parentd34a9bb38f1f3337e7308c36601ddc2d25584ce1 (diff)
downloademacs-e9dfbb4a2cc9fd0b5a542114803a60732a375599.tar.gz
* configure.in: Do not override user crt-dir, even if faulty.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 956167bd4c8..d7e4efe51ed 100644
--- a/configure.in
+++ b/configure.in
@@ -1040,6 +1040,8 @@ done
if test "x$crt_files" != x; then
## If user specified a crt-dir, use that unconditionally.
+ crt_gcc=no
+
if test "X$CRT_DIR" = "X"; then
CRT_DIR=/usr/lib # default
@@ -1063,18 +1065,17 @@ if test "x$crt_files" != x; then
hpux10-20) CRT_DIR=/lib ;;
esac
+ test "x${GCC}" = xyes && crt_gcc=yes
+
fi # CRT_DIR = ""
crt_missing=
- crt_gcc=no
- test "x${GCC}" = xyes && crt_gcc=yes
for file in $crt_files; do
## If we're using gcc, try to determine it automatically by asking
## gcc. [If this doesn't work, CRT_DIR will remain at the
## system-dependent default from above.]
- ## Note that this overrides a faulty with-crt-dir.
if test $crt_gcc = yes && test ! -e $CRT_DIR/$file; then
crt_file=`$CC --print-file-name=$file 2>/dev/null`