summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDave Love <fx@gnu.org>2000-01-05 22:11:33 +0000
committerDave Love <fx@gnu.org>2000-01-05 22:11:33 +0000
commit3cc9d384b9507f50769679443b4e06029f7203a4 (patch)
treeb274f96c362d2574db851c4b05acdf3ffccd128f /configure.in
parent404fa7d6e3ffab57b38f58902a0dcb0f16c150dd (diff)
downloademacs-3cc9d384b9507f50769679443b4e06029f7203a4.tar.gz
Check for jerror.h as well as libjpeg.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index b58e0e7fd2f..ba378ee17cc 100644
--- a/configure.in
+++ b/configure.in
@@ -1708,7 +1708,10 @@ if test "${HAVE_X11}" = "yes"; then
if test "${with_jpeg}" != "no"; then
old_c_flags="${CFLAGS}"
CFLAGS="${LD_SWITCH_X_SITE} ${CFLAGS}"
- AC_CHECK_LIB(jpeg, jpeg_destroy_compress, HAVE_JPEG=yes, , -lX11)
+ dnl Checking for jpeglib.h can lose becsue of a redefinition of
+ dnl HAVE_STDLIB_H.
+ AC_CHECK_HEADER(jerror.h,
+ AC_CHECK_LIB(jpeg, jpeg_destroy_compress, HAVE_JPEG=yes, , -lX11))
CFLAGS="${old_c_flags}"
fi