summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKarl Heuer <kwzh@gnu.org>1995-07-17 21:54:33 +0000
committerKarl Heuer <kwzh@gnu.org>1995-07-17 21:54:33 +0000
commitc05a41b90fcbd8490a74ac7f70964016888cc2e0 (patch)
treedbab039e08d46cd0ae126a1e98a86d466c8ccbba /configure.in
parent5d8b8d0e026ef857cfbe1e165123c3c076b13be4 (diff)
downloademacs-c05a41b90fcbd8490a74ac7f70964016888cc2e0.tar.gz
(mips-dec-ultrix*): Assume version 4.3.
(mips-dec-ultrix4.[12]): New alternative for old versions.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 12 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 0afa1bb63c5..0373af45eba 100644
--- a/configure.in
+++ b/configure.in
@@ -259,9 +259,12 @@ case "${canonical}" in
mips-dec-ultrix[0-3].* | mips-dec-ultrix4.0* | mips-dec-bsd4.2* )
machine=pmax opsys=bsd4-2
;;
- mips-dec-ultrix* | mips-dec-bsd* )
+ mips-dec-ultrix4.[12]* | mips-dec-bsd* )
machine=pmax opsys=bsd4-3
;;
+ mips-dec-ultrix* )
+ machine=pmax opsys=ultrix4-3
+ ;;
mips-dec-osf* )
machine=pmax opsys=osf1
;;
@@ -1170,13 +1173,13 @@ if test "${HAVE_X11}" = "yes"; then
LIBS="$LD_SWITCH_X_SITE $LIBX $LIBS"
CFLAGS="$C_SWITCH_X_SITE $CFLAGS"
- if test "${HAVE_XFREE386}" = "yes" && test "${opsys}" = "linux"; then
- AC_MSG_CHECKING(whether XFree86 needs -b to link)
+ if test "${opsys}" = "linux"; then
+ AC_MSG_CHECKING(whether X on GNU/Linux needs -b to link)
AC_TRY_LINK([],
[XOpenDisplay ("foo");],
- [xfree86_first_failure=no],
- [xfree86_first_failure=yes])
- if test "${xfree86_first_failure}" = "yes"; then
+ [xlinux_first_failure=no],
+ [xlinux_first_failure=yes])
+ if test "${xlinux_first_failure}" = "yes"; then
OLD_LD_SWITCH_X_SITE="$LD_SWITCH_X_SITE"
OLD_C_SWITCH_X_SITE="$C_SWITCH_X_SITE"
OLD_CPPFLAGS="$CPPFLAGS"
@@ -1187,9 +1190,9 @@ if test "${HAVE_X11}" = "yes"; then
LIBS="$LIBS -b i486-linuxaout"
AC_TRY_LINK([],
[XOpenDisplay ("foo");],
- [xfree86_second_failure=no],
- [xfree86_second_failure=yes])
- if test "${xfree86_second_failure}" = "yes"; then
+ [xlinux_second_failure=no],
+ [xlinux_second_failure=yes])
+ if test "${xlinux_second_failure}" = "yes"; then
# If we get the same failure with -b, there is no use adding -b.
# So take it out. This plays safe.
LD_SWITCH_X_SITE="$OLD_LD_SWITCH_X_SITE"