summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid J. MacKenzie <djm@gnu.org>1994-08-31 14:31:25 +0000
committerDavid J. MacKenzie <djm@gnu.org>1994-08-31 14:31:25 +0000
commitd81b69e851f108e9b9ea32846454132009ad09c3 (patch)
tree1d53f410743dc931d3e18e82fa410b0b3236ea20 /configure.in
parent34c021e694afd8c563e967f52ef45905941b04c2 (diff)
downloademacs-d81b69e851f108e9b9ea32846454132009ad09c3.tar.gz
*** empty log message ***
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in149
1 files changed, 43 insertions, 106 deletions
diff --git a/configure.in b/configure.in
index abf68ea4af1..ea4d9adf6ea 100644
--- a/configure.in
+++ b/configure.in
@@ -33,13 +33,13 @@ AC_ARG_WITH(x-toolkit,
n | no ) val=no ;;
l | lu | luc | luci | lucid ) val=lucid ;;
a | at | ath | athe | athena ) val=athena ;;
-# These don't currently work.
-# m | mo | mot | moti | motif ) val=motif ;;
-# o | op | ope | open | open- | open-l | open-lo \
-# | open-loo | open-look ) val=open-look ;;
+dnl These don't currently work.
+dnl m | mo | mot | moti | motif ) val=motif ;;
+dnl o | op | ope | open | open- | open-l | open-lo \
+dnl | open-loo | open-look ) val=open-look ;;
* )
-[#] AC_MSG_ERROR([the \`--with-x-toolkit' option is supposed to have a value
-[#]which is \`yes', \`no', \`lucid', \`athena', \`motif' or \`open-look'.])
+dnl AC_MSG_ERROR([the \`--with-x-toolkit' option is supposed to have a value
+dnl which is \`yes', \`no', \`lucid', \`athena', \`motif' or \`open-look'.])
AC_MSG_ERROR([the \`--with-x-toolkit' option is supposed to have a value
which is \`yes', \`no', \`lucid', or \`athena'.
Currently, \`yes', \`athena' and \`lucid' are synonyms.])
@@ -49,17 +49,14 @@ Currently, \`yes', \`athena' and \`lucid' are synonyms.])
])
AC_ARG_WITH(gcc,
[ --with-gcc Use GCC to compile Emacs])
-AC_ARG_ENABLE(in-place,
-[ --enable-in-place Use libraries and data files directly out of the
- source tree])
-AC_ARG_ENABLE(single-tree,
-[ --enable-single-tree Create a directory tree at DIR which looks like:
- .../DIR/bin/CONFIGNAME (emacs, etags, etc.)
- .../DIR/bin/CONFIGNAME/etc (movemail, etc.)
- .../DIR/common/lisp (emacs' lisp files)
- .../DIR/common/site-lisp (local lisp files)
- .../DIR/common/lib (DOC, TUTORIAL, etc.)
- .../DIR/common/lock (lockfiles)])
+dnl AC_ARG_ENABLE(single-tree,
+dnl [ --enable-single-tree Create a directory tree at DIR which looks like:
+dnl .../DIR/bin/CONFIGNAME (emacs, etags, etc.)
+dnl .../DIR/bin/CONFIGNAME/etc (movemail, etc.)
+dnl .../DIR/common/lisp (emacs' lisp files)
+dnl .../DIR/common/site-lisp (local lisp files)
+dnl .../DIR/common/lib (DOC, TUTORIAL, etc.)
+dnl .../DIR/common/lock (lockfiles)])
#### Make srcdir absolute, if it isn't already. It's important to
#### avoid running the path through pwd unnecessary, since pwd can
@@ -840,82 +837,32 @@ AC_LONG_FILE_NAMES
dnl other checks for UNIX variants
#### Choose a window system.
-AC_MSG_CHECKING(for specified window system)
-window_system=''
-case "${with_x}" in
- yes ) window_system=${window_system}x11 ;;
- no ) window_system=${window_system}none ;;
-esac
-
-case "${window_system}" in
- .* ) ;;
- * )
- case "${with_x11}" in
- yes ) window_system=x11 ;;
- no ) window_system=none ;;
- esac
- case "${with_x10}" in
- yes ) window_system=x10 ;;
- no ) window_system=none ;;
- esac ;;
-esac
-
-case "${window_system}" in
- "none" | "x11" | "x10" ) ;;
- "" )
- # --x-includes or --x-libraries implies --with-x11.
- if test "${x_includes}" != NONE || test "${x_libraries}" != NONE; then
- window_system=x11
+case "${with_x10}" in
+ yes ) window_system=x10 ;;
+ no ) window_system=none ;;
+ *) test -n "$with_x11" && with_x="$with_x11"
+ AC_FIND_X
+ if test "$no_x" = yes; then
+ window_system=none
else
- # If the user didn't specify a window system and we found X11, use it.
- if test -r /usr/lib/libX11.a \
- -o -d /usr/include/X11 \
- -o -d /usr/X386/include \
- -o -d ${x_includes}/X11 ; then
- window_system=x11
- fi
- fi
- ;;
- * )
- AC_MSG_ERROR(Don't specify a window system more than once.)
- ;;
-esac
-
-AC_MSG_RESULT(${window_system})
-
-case "${window_system}" in
- "" | "x11" )
- ### If the user hasn't specified where we should find X, try
- ### letting Autoconf figure that out.
- if test "${x_includes}" = NONE && test "${x_libraries}" = NONE; then
- AC_FIND_X
- fi
- if test "${x_includes}" != NONE || test "${x_libraries}" != NONE; then
window_system=x11
fi
;;
esac
-test -z "${window_system}" && window_system=none
-
test "${x_libraries}" != NONE && LD_SWITCH_X_SITE="-L${x_libraries}"
test "${x_libraries}" != NONE && LD_SWITCH_X_SITE_AUX="-R${x_libraries}"
test "${x_includes}" != NONE && C_SWITCH_X_SITE="-I${x_includes}"
-# Avoid forcing the search of /usr/include before fixed include files.
-if test "$C_SWITCH_X_SITE" = "-I/usr/include"; then
- C_SWITCH_X_SITE=" "
-fi
-
case "${window_system}" in
x11 )
HAVE_X_WINDOWS=yes
HAVE_X11=yes
case "${with_x_toolkit}" in
athena | lucid ) USE_X_TOOLKIT=LUCID ;;
- motif ) USE_X_TOOLKIT=MOTIF ;;
- open-look ) USE_X_TOOLKIT=OPEN_LOOK ;;
+dnl motif ) USE_X_TOOLKIT=MOTIF ;;
+dnl open-look ) USE_X_TOOLKIT=OPEN_LOOK ;;
* ) USE_X_TOOLKIT=none ;;
esac
;;
@@ -1223,36 +1170,26 @@ if test "${LISP_FLOAT_TYPE}" = "yes" ; then
AC_DEFINE(LISP_FLOAT_TYPE)
fi
-# ====================== Developer's configuration =======================
-
-# The following assignments make sense if you're running Emacs on a single
-# machine, one version at a time, and you want changes to the lisp and etc
-# directories in the source tree to show up immediately in your working
-# environment. It saves a great deal of disk space by not duplicating the
-# lisp and etc directories.
-
-if test "$enable_in_place" = "yes"; then
- lispdir='${srcdir}/lisp'
- locallisppath='${srcdir}/site-lisp'
- etcdir='${srcdir}/etc'
- lockdir='${srcdir}/lock'
- # We used to make archlibdir and docdir absolute,
- # but that caused trouble with automounters.
- archlibdir='${srcdir}/lib-src'
- docdir='${srcdir}/etc'
- infodir='${srcdir}/info'
-elif test "$enable_single_tree" = "yes"; then
- bindir='${exec_prefix}/bin/${configuration}'
- datadir='${prefix}/common'
- statedir='${prefix}/common'
- libdir='${bindir}'
- lispdir='${prefix}/common/lisp'
- locallisppath='${prefix}/common/site-lisp'
- lockdir='${prefix}/common/lock'
- archlibdir='${libdir}/etc'
- etcdir='${prefix}/common/data'
- docdir='${prefix}/common/data'
-fi
+dnl # ====================== Developer's configuration =======================
+dnl
+dnl # The following assignments make sense if you're running Emacs on a single
+dnl # machine, one version at a time, and you want changes to the lisp and etc
+dnl # directories in the source tree to show up immediately in your working
+dnl # environment. It saves a great deal of disk space by not duplicating the
+dnl # lisp and etc directories.
+dnl
+dnl if test "$enable_single_tree" = "yes"; then
+dnl bindir='${exec_prefix}/bin/${configuration}'
+dnl datadir='${prefix}/common'
+dnl statedir='${prefix}/common'
+dnl libdir='${bindir}'
+dnl lispdir='${prefix}/common/lisp'
+dnl locallisppath='${prefix}/common/site-lisp'
+dnl lockdir='${prefix}/common/lock'
+dnl archlibdir='${libdir}/etc'
+dnl etcdir='${prefix}/common/data'
+dnl docdir='${prefix}/common/data'
+dnl fi
#### Report on what we decided to do.
echo "