summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid J. MacKenzie <djm@gnu.org>1995-05-06 21:27:16 +0000
committerDavid J. MacKenzie <djm@gnu.org>1995-05-06 21:27:16 +0000
commit7232a667a3a54ecc8c485def427f3b9b660995bf (patch)
treeb0d4c06f97e99d1866534edac49a484f412617fe /configure.in
parenta3446cca6af9b5f785c50fd7ca5758fb6fdd2c7a (diff)
downloademacs-7232a667a3a54ecc8c485def427f3b9b660995bf.tar.gz
Make sure CDPATH doesn't mess up PWD check.
Check whether X bitmaps are in X11/bitmaps instead of bitmaps. Use fmod instead of logb in -lm check.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index db48cedea6c..bb91847034f 100644
--- a/configure.in
+++ b/configure.in
@@ -65,6 +65,8 @@ case "${srcdir}" in
. )
## We may be able to use the $PWD environment variable to make this
## absolute. But sometimes PWD is inaccurate.
+ ## Make sure CDPATH doesn't affect cd (in case PWD is relative).
+ CDPATH=
if test "${PWD}" != "" && test "`(cd ${PWD} ; sh -c pwd)`" = "`pwd`" ;
then
srcdir="$PWD"
@@ -939,6 +941,8 @@ fi
if test x"${x_includes}" = x; then
bitmapdir=/usr/include/X11/bitmaps
+elif test -d "${x_includes}/X11/bitmaps"; then
+ bitmapdir="${x_includes}/X11/bitmaps"
else
bitmapdir="${x_includes}/bitmaps"
fi
@@ -1152,8 +1156,11 @@ AC_TRY_LINK([#include <netdb.h>],
AC_FUNC_ALLOCA
-# logb and frexp are found in -lm on most systems.
-AC_CHECK_LIB(m, logb)
+# fmod, logb, and frexp are found in -lm on most systems.
+# On HPUX 9.01, -lm does not contain logb, so check for fmod.
+# If some other system has -lm with logb and/or frexp but not fmod,
+# we will have to try yet again...
+AC_CHECK_LIB(m, fmod)
AC_CHECK_FUNCS(gettimeofday gethostname dup2 rename closedir mkdir rmdir \
random lrand48 bcopy bcmp logb frexp fmod drem ftime res_init setsid \
strerror fpathconf select mktime eaccess getpagesize)