summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid J. MacKenzie <djm@gnu.org>1994-09-01 15:30:26 +0000
committerDavid J. MacKenzie <djm@gnu.org>1994-09-01 15:30:26 +0000
commit16c525249e4ffdfbdec2bff98516d85af9df558e (patch)
tree446e82ea9f6ab36a5b8405a2017c46e93aee9e12 /configure.in
parent3b7ce9629d98b95e9103ece7313e29b05d7e7652 (diff)
downloademacs-16c525249e4ffdfbdec2bff98516d85af9df558e.tar.gz
entered into RCS
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 057da09528c..471d952e4a3 100644
--- a/configure.in
+++ b/configure.in
@@ -2,7 +2,7 @@ dnl This is an autoconf script.
dnl To rebuild the `configure' script from this, execute the command
dnl autoconf
dnl in the directory containing this script.
-AC_PREREQ(1.106)dnl
+AC_PREREQ(1.110)dnl
AC_INIT(src/lisp.h)
AC_CONFIG_HEADER(src/config.h)
@@ -100,6 +100,7 @@ fi
AC_CANONICAL_HOST
canonical=$host
+configuration=$host_alias
changequote(, )dnl
@@ -1089,6 +1090,10 @@ if test $ok_so_far = yes; then
AC_DEFINE(HAVE_INET_SOCKETS)
fi
+if test -f /usr/lpp/X11/bin/smt.exp; then
+ AC_DEFINE(HAVE_AIX_SMT_EXP)
+fi
+
# Set up the CFLAGS for real compilation, so we can substitute it.
CFLAGS="$REAL_CFLAGS"
@@ -1101,10 +1106,6 @@ if test x"${version}" = x; then
AC_MSG_ERROR(can't find current emacs version in \`${srcdir}/lisp/version.el'.)
fi
-if test -f /usr/lpp/X11/bin/smt.exp; then
- AC_DEFINE(HAVE_AIX_SMT_EXP)
-fi
-
### Specify what sort of things we'll be editing into Makefile and config.h.
### Use configuration here uncanonicalized to avoid exceeding size limits.
AC_SUBST(version)
@@ -1217,6 +1218,7 @@ changequote([, ])dnl
AC_OUTPUT(Makefile lib-src/Makefile.in oldXMenu/Makefile \
lwlib/Makefile src/Makefile.in, [
+
### Make the necessary directories, if they don't exist.
for dir in ./src ./lib-src ./cpp ./oldXMenu ./lwlib ./etc ; do
if test ! -d ${dir}; then