summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKarl Heuer <kwzh@gnu.org>1997-09-24 16:11:32 +0000
committerKarl Heuer <kwzh@gnu.org>1997-09-24 16:11:32 +0000
commit70aaa3d7f8b1137b6ef18697ff519ade4281a62f (patch)
tree5d4c7b75af737b4bceeedc08b15be8543f8d9983 /configure.in
parentc28b31d3ef017d4a90d842513463097cb29f398d (diff)
downloademacs-70aaa3d7f8b1137b6ef18697ff519ade4281a62f.tar.gz
(with-pop, with-kerberos): Need to check Kerberos
libraries in reverse order, so that libraries will appear in the correct dependency order on the link line (and so that the configure checks themselves will work properly when early libraries depend on later ones).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 7f4af864cbf..33f233d27dd 100644
--- a/configure.in
+++ b/configure.in
@@ -1587,15 +1587,15 @@ AC_CHECK_LIB(ncurses, tparm)
# These tell us which Kerberos-related libraries to use.
if test "${with_kerberos+set}" = set; then
+ AC_CHECK_LIB(com_err, com_err)
+ AC_CHECK_LIB(crypto, mit_des_cbc_encrypt)
+ AC_CHECK_LIB(krb5, krb5_init_context)
if test "${with_kerberos5+set}" != set; then
- AC_CHECK_LIB(krb, krb_get_cred,,
- AC_CHECK_LIB(krb4, krb_get_cred))
AC_CHECK_LIB(des, des_cbc_encrypt,,
AC_CHECK_LIB(des425, des_cbc_encrypt))
+ AC_CHECK_LIB(krb, krb_get_cred,,
+ AC_CHECK_LIB(krb4, krb_get_cred))
fi
- AC_CHECK_LIB(krb5, krb5_init_context)
- AC_CHECK_LIB(crypto, mit_des_cbc_encrypt)
- AC_CHECK_LIB(com_err, com_err)
if test "${with_kerberos5+set}" = set; then
AC_CHECK_HEADERS(krb5.h)