summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRichard M. Stallman <rms@gnu.org>1996-10-02 21:44:00 +0000
committerRichard M. Stallman <rms@gnu.org>1996-10-02 21:44:00 +0000
commit6188e1c46673328948ed822d953b229786fd0e07 (patch)
tree296fc9cd7a1ceea50ad06d2b39a9642201e84ede /configure.in
parentad7eaaa2efefe39506b5ed9d3bb150fe22f83aa5 (diff)
downloademacs-6188e1c46673328948ed822d953b229786fd0e07.tar.gz
Fetch LD_SWITCH_SYSTEM and LD_SWITCH_MACHINE
from config.h and use them in $ac_link.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e1def3bd6b2..3979482cf5a 100644
--- a/configure.in
+++ b/configure.in
@@ -1212,6 +1212,17 @@ configure___ system_malloc=no
#define C_OPTIMIZE_SWITCH -O
#endif
+#ifndef LD_SWITCH_MACHINE
+#define LD_SWITCH_MACHINE
+#endif
+
+#ifndef LD_SWITCH_SYSTEM
+#define LD_SWITCH_SYSTEM
+#endif
+
+configure___ ld_switch_system=LD_SWITCH_SYSTEM
+configure___ ld_switch_maldhine=LD_SWITCH_MACHINE
+
#ifdef THIS_IS_CONFIGURE
/* Get the CFLAGS for tests in configure. */
@@ -1248,6 +1259,8 @@ fi
changequote([, ])dnl
rm ${tempcname}
+ac_link="$ac_link $ld_switch_machine $ld_switch_system"
+
### Compute the unexec source name from the object name.
UNEXEC_SRC="`echo ${unexec} | sed 's/\.o/.c/'`"