summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRichard M. Stallman <rms@gnu.org>1997-04-11 08:24:41 +0000
committerRichard M. Stallman <rms@gnu.org>1997-04-11 08:24:41 +0000
commit2ed50189a3309929f00f9994ac4c71bf7fe33d37 (patch)
tree9e51ca94b9da593dced46358670ee8b57812ffb6 /configure.in
parentb304d9047231f3c82b200086a8b4a4653b45e47c (diff)
downloademacs-2ed50189a3309929f00f9994ac4c71bf7fe33d37.tar.gz
(doug_lea_malloc): First check for SYSTEM_MALLOC,
in case it is desirable to disable the GNU malloc features withglibc.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 0452c255271..381cb7128ce 100644
--- a/configure.in
+++ b/configure.in
@@ -1284,15 +1284,18 @@ GNU_MALLOC=yes
doug_lea_malloc=yes
AC_CHECK_FUNC(malloc_get_state, ,doug_lea_malloc=no)
AC_CHECK_FUNC(malloc_set_state, ,doug_lea_malloc=no)
-if test "$doug_lea_malloc" = "yes" ; then
- GNU_MALLOC_reason="
- (Using new Doug Lea's new malloc from the GNU C Library.)"
- AC_DEFINE(DOUG_LEA_MALLOC)
-elif test "${system_malloc}" = "yes"; then
+if test "${system_malloc}" = "yes"; then
GNU_MALLOC=no
GNU_MALLOC_reason="
(The GNU allocators don't work with this system configuration.)"
fi
+if test "$doug_lea_malloc" = "yes" ; then
+ if test "$GNU_MALLOC" = yes ; then
+ GNU_MALLOC_reason="
+ (Using new Doug Lea's new malloc from the GNU C Library.)"
+ fi
+ AC_DEFINE(DOUG_LEA_MALLOC)
+fi
if test x"${REL_ALLOC}" = x; then
REL_ALLOC=${GNU_MALLOC}