summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRichard M. Stallman <rms@gnu.org>1996-05-21 18:04:41 +0000
committerRichard M. Stallman <rms@gnu.org>1996-05-21 18:04:41 +0000
commit73dc0ac8f5c06e26a09164e32e4217750d886228 (patch)
treec8f96c7f258db7fd2db0ccf0548c22e02eb1cdfd /configure.in
parentfd3ba6a2a459d90b7c827357d95a20df27ee6a83 (diff)
downloademacs-73dc0ac8f5c06e26a09164e32e4217750d886228.tar.gz
(ncurses): Check this after checking fns like strerror.
(HAVE_NCURSES): Look for library named ncurses. (setlocale): Check for it. (*-*-sysv4.2*): If no /usr/ccs/lib/cpp, use /lib/cpp.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 12 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 17eb3670d2e..ed2669bbd10 100644
--- a/configure.in
+++ b/configure.in
@@ -873,7 +873,11 @@ if test x"${opsys}" = x; then
opsys=usg5-4 ;;
*-sysv4.[2-9]* | *-sysvr4.[2-9]* )
if [ x$NON_GNU_CPP = x ]; then
- NON_GNU_CPP=/usr/ccs/lib/cpp
+ if [ -f /usr/ccs/lib/cpp ]; then
+ NON_GNU_CPP=/usr/ccs/lib/cpp
+ else
+ NON_GNU_CPP=/lib/cpp
+ fi
fi
opsys=usg5-4-2 ;;
*-sysv4* | *-sysvr4* ) opsys=usg5-4 ;;
@@ -1235,12 +1239,6 @@ AC_CHECK_LIB(Xbsd, main, LD_SWITCH_X_SITE="$LD_SWITCH_X_SITE -lXbsd")
AC_CHECK_LIB(pthreads, cma_open)
-dnl If we can find a tparm in libcurses.a, it means we have ncurses.
-AC_CHECK_LIB(curses, tparm, HAVE_NCURSES=yes)
-if test x"${HAVE_NCURSES}" = "xyes" ; then
- AC_DEFINE(HAVE_NCURSES)
-fi
-
AC_MSG_CHECKING(for XFree86)
if test -d /usr/X386/include; then
HAVE_XFREE386=yes
@@ -1373,7 +1371,13 @@ AC_CHECK_LIB(m, sqrt)
AC_CHECK_FUNCS(gettimeofday gethostname dup2 rename closedir mkdir rmdir \
random lrand48 bcopy bcmp logb frexp fmod ftime res_init setsid \
-strerror fpathconf select mktime eaccess getpagesize tzset)
+strerror fpathconf select mktime eaccess getpagesize tzset setlocale)
+
+# Check this now, so that we will NOT find the above functions in ncurses.
+# That is because we have not set up to link ncurses in lib-src.
+# It's better to believe a function is not available
+# than to expect to find it in ncurses.
+AC_CHECK_LIB(ncurses, tparm)
AC_MSG_CHECKING(whether localtime caches TZ)
AC_CACHE_VAL(emacs_cv_localtime_cache,