summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRichard M. Stallman <rms@gnu.org>1996-06-09 20:52:47 +0000
committerRichard M. Stallman <rms@gnu.org>1996-06-09 20:52:47 +0000
commit147e2ffebd6ea35de8aca216a5588050208c2bb0 (patch)
treefe2871dc263c2c21613b3f322b7b4fddadf7c97d /configure.in
parent4dc4b0b522534a3087986141114cfce669da5205 (diff)
downloademacs-147e2ffebd6ea35de8aca216a5588050208c2bb0.tar.gz
Always check for HAVE_X11R5.
Separately decide whether to use a toolkit by default. If X11R5 is missing the Xaw headers, default to --with-x-toolkit=no. (powerpc-*-solaris2*): Use ibmrs6000, not rs6000.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 24 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 7fd45c879be..5663dd33e7d 100644
--- a/configure.in
+++ b/configure.in
@@ -49,7 +49,7 @@ dnl This should be the last --with option, because --with-x is
dnl added later on when we find the path of X, and it's best to
dnl keep them together visually.
AC_ARG_WITH(x-toolkit,
-[ --with-x-toolkit=KIT use an X toolkit (KIT = yes/lucid/athena/motif)],
+[ --with-x-toolkit=KIT use an X toolkit (KIT = yes/lucid/athena/motif/no)],
[ case "${withval}" in
y | ye | yes ) val=athena ;;
n | no ) val=no ;;
@@ -691,7 +691,7 @@ case "${canonical}" in
m68* ) machine=sun3 ;;
i[345]86-sun-sunos[34]* ) machine=sun386 ;;
i[345]86-*-* ) machine=intel386 ;;
- powerpc* | rs6000* ) machine=rs6000 ;;
+ powerpc* | rs6000* ) machine=ibmrs6000 ;;
sparc* ) machine=sparc ;;
* ) unported=yes ;;
esac
@@ -1320,17 +1320,34 @@ fail;
[AC_MSG_RESULT(before 6)])
fi
-if test x"${USE_X_TOOLKIT}" = xmaybe; then
+if test "${window_system}" = "x11"; then
AC_MSG_CHECKING(X11 version 5)
AC_TRY_LINK([#include <X11/Xlib.h>],
[#if XlibSpecificationRelease < 5
fail;
#endif
-], [AC_MSG_RESULT(5 or newer; use toolkit by default)
- USE_X_TOOLKIT=LUCID
+], [AC_MSG_RESULT(5 or newer)
+ HAVE_X11R5=yes
AC_DEFINE(HAVE_X11R5)],
- [AC_MSG_RESULT(before 5; do not use toolkit by default)
- USE_X_TOOLKIT=none])
+ [
+ HAVE_X11R5=no
+ AC_MSG_RESULT(before 5)])
+fi
+
+if test x"${USE_X_TOOLKIT}" = xmaybe; then
+ if test x"${HAVE_X11R5}" = xyes; then
+ AC_MSG_CHECKING(X11 version 5 with Xaw)
+ AC_TRY_LINK([
+ #include <X11/Intrinsic.h>
+ #include <X11/Xaw/Simple.h>],
+ [],
+ [AC_MSG_RESULT(5 or newer, with Xaw; use toolkit by default)
+ USE_X_TOOLKIT=LUCID],
+ [AC_MSG_RESULT(before 5 or no Xaw; do not use toolkit by default)
+ USE_X_TOOLKIT=none])
+ else
+ USE_X_TOOLKIT=none
+ fi
fi
X_TOOLKIT_TYPE=$USE_X_TOOLKIT