summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRichard M. Stallman <rms@gnu.org>1996-02-04 20:16:38 +0000
committerRichard M. Stallman <rms@gnu.org>1996-02-04 20:16:38 +0000
commite7f43767ebb538e8673fc3691a628ef4875b358d (patch)
tree48375560a425ee798e5a2ba65161d720841a4f5e /configure.in
parent026451202efb78aa425597babd90ea3b01604e49 (diff)
downloademacs-e7f43767ebb538e8673fc3691a628ef4875b358d.tar.gz
(LD_RUN_PATH): Prepend x_libraries to this envvar.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fb7ea9f4554..8bcd982eb55 100644
--- a/configure.in
+++ b/configure.in
@@ -1253,6 +1253,15 @@ if test "${HAVE_X11}" = "yes"; then
LIBS="$LIBX $LIBS"
CFLAGS="$C_SWITCH_X_SITE $CFLAGS"
+ # On Solaris, arrange for LD_RUN_PATH to point to the X libraries for tests.
+ # This is handled by LD_SWITCH_X_SITE_AUX during the real build,
+ # but it's more convenient here to set LD_RUN_PATH
+ # since this also works on hosts that don't understand LD_SWITCH_X_SITE_AUX.
+ if test "${x_libraries}" != NONE && test -n "${x_libraries}"; then
+ LD_RUN_PATH=$x_libraries${LD_RUN_PATH+:}$LD_RUN_PATH
+ export LD_RUN_PATH
+ fi
+
if test "${opsys}" = "linux"; then
AC_MSG_CHECKING(whether X on GNU/Linux needs -b to link)
AC_TRY_LINK([],