summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKarl Heuer <kwzh@gnu.org>1995-05-30 23:26:56 +0000
committerKarl Heuer <kwzh@gnu.org>1995-05-30 23:26:56 +0000
commitb183f2c0ddeaf0162de8240999516b5fcc87f742 (patch)
tree7460d3f63b7bdb602e8041a128ab77e14c6f273e /configure.in
parentf824dab15a3b41a6c12d23b9eb51c037da2eb682 (diff)
downloademacs-b183f2c0ddeaf0162de8240999516b5fcc87f742.tar.gz
Use x_includes, not x_libraries, for -I.
Make bitmapdir a colon-separated list.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 0bafbc1c3b9..33f8540258d 100644
--- a/configure.in
+++ b/configure.in
@@ -940,15 +940,24 @@ if test "${x_libraries}" != NONE && test -n "${x_libraries}"; then
LD_SWITCH_X_SITE_AUX=-R`echo ${x_libraries} | sed -e "s/:/ -R/g"`
fi
if test "${x_includes}" != NONE && test -n "${x_includes}"; then
- C_SWITCH_X_SITE=-I`echo ${x_libraries} | sed -e "s/:/ -I/g"`
+ C_SWITCH_X_SITE=-I`echo ${x_includes} | sed -e "s/:/ -I/g"`
fi
if test x"${x_includes}" = x; then
bitmapdir=/usr/include/X11/bitmaps
-elif test -d "${x_includes}/X11/bitmaps"; then
- bitmapdir="${x_includes}/X11/bitmaps"
else
- bitmapdir="${x_includes}/bitmaps"
+ # accumulate include directories that have X11 bitmap sudirectories
+ bmd_acc="dummyval"
+ for bmd in `echo ${x_includes} | sed -e "s/:/ /g"`; do
+ if test -d "${bmd}/X11/bitmaps"; then
+ bmd_acc="${bmd_acc}:${bmd}/X11/bitmaps"
+ elif test -d "${bmd}/bitmaps"; then
+ bmd_acc="${bmd_acc}:${bmd}/bitmaps"
+ fi
+ done
+ if test ${bmd_acc} != "dummyval"; then
+ bitmapdir=`echo ${bmd_acc} | sed -e "s/^dummyval://"`
+ fi
fi
case "${window_system}" in