summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRichard M. Stallman <rms@gnu.org>1995-07-01 20:03:39 +0000
committerRichard M. Stallman <rms@gnu.org>1995-07-01 20:03:39 +0000
commit8f990177faa5cf6e4fe6117dda5dbbe3d5517fef (patch)
treedffec13ba53e6eee55b4b2f3923a91fd2954e9df /configure.in
parent9d79d114ce7fa35a2e908c7242b5f6bec4c43761 (diff)
downloademacs-8f990177faa5cf6e4fe6117dda5dbbe3d5517fef.tar.gz
Use sunos4shr normally for Sunos 4.1.[3-9].
(mips-mips-riscos5*): New alternative. (bindir, datadir, sharedstatedir, libexecdir) (mandir, infodir, archlibdir): Initializations deleted. On hpux9, use hpux9-x11r4.h if we have X11R4. On hpux9shr, use hpux9shxr4.h. Added target mips-dec-mach_bsd4.3.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 26 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 1e5dfba7ad2..a93eedf9d8c 100644
--- a/configure.in
+++ b/configure.in
@@ -6,18 +6,11 @@ AC_PREREQ(2.0)dnl
AC_INIT(src/lisp.h)
AC_CONFIG_HEADER(src/config.h)
-bindir='${exec_prefix}/bin'
-datadir='${prefix}/share'
-sharedstatedir='${prefix}/com'
-libexecdir='${exec_prefix}/libexec'
-mandir='${prefix}/man/man1'
-infodir='${prefix}/info'
lispdir='${datadir}/emacs/${version}/lisp'
locallisppath='${datadir}/emacs/site-lisp'
lisppath='${locallisppath}:${lispdir}'
etcdir='${datadir}/emacs/${version}/etc'
lockdir='${sharedstatedir}/emacs/lock'
-archlibdir='${libexecdir}/emacs/${version}/${configuration}'
docdir='${datadir}/emacs/${version}/etc'
AC_ARG_WITH(gcc,
@@ -271,6 +264,9 @@ case "${canonical}" in
mips-dec-osf* )
machine=pmax opsys=osf1
;;
+ mips-dec-mach_bsd4.3* )
+ machine=pmax opsys=mach-bsd4-3
+ ;;
## Motorola Delta machines
m68k-motorola-sysv* | m68000-motorola-sysv* )
@@ -529,6 +525,11 @@ case "${canonical}" in
NON_GNU_CC="cc -systype bsd43"
NON_GNU_CPP="cc -systype bsd43 -E"
;;
+ mips-mips-riscos5* )
+ machine=mips4 opsys=riscos5
+ NON_GNU_CC="cc -systype bsd43"
+ NON_GNU_CPP="cc -systype bsd43 -E"
+ ;;
mips-mips-bsd* )
machine=mips opsys=bsd4-3
;;
@@ -653,7 +654,8 @@ case "${canonical}" in
## The Sun386 didn't get past 4.0.
i[345]86-*-sunos4 ) opsys=sunos4-0 ;;
*-sunos4.0* ) opsys=sunos4-0 ;;
- *-sunos4.1.[3-9]* | *-sunos4shr* ) opsys=sunos4shr
+ *-sunos4.1.[3-9]* )
+ opsys=sunos4shr
NON_GNU_CPP=/usr/lib/cpp
;;
*-sunos4* | *-sunos ) opsys=sunos4-1
@@ -989,6 +991,22 @@ case ${HAVE_X11} in
yes ) HAVE_X_MENU=yes ;;
esac
+if test "${opsys}" = "hpux9"; then
+ case "${x_libraries}" in
+ *X11R4* )
+ opsysfile="s/hpux9-x11r4.h"
+ ;;
+ esac
+fi
+
+if test "${opsys}" = "hpux9shr"; then
+ case "${x_libraries}" in
+ *X11R4* )
+ opsysfile="s/hpux9shxr4.h"
+ ;;
+ esac
+fi
+
#### Extract some information from the operating system and machine files.
AC_CHECKING([the machine- and system-dependent files to find out