summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRichard M. Stallman <rms@gnu.org>1995-08-17 17:48:58 +0000
committerRichard M. Stallman <rms@gnu.org>1995-08-17 17:48:58 +0000
commit020a2339b49a6fc095613a7b5907491acb01a85f (patch)
treec6ff32aaa7f97794a80dd05a8563b2d78b61015b /configure.in
parentb6d19d2702e19e6453f92bcc24911598a33b6246 (diff)
downloademacs-020a2339b49a6fc095613a7b5907491acb01a85f.tar.gz
(RANLIB): Substitute this into makefiles.
Set it specially on solaris; set it by default on other systems. Fix previous Alpha change.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 87d9badb71f..ea656331423 100644
--- a/configure.in
+++ b/configure.in
@@ -164,7 +164,7 @@ case "${canonical}" in
machine=alliant-2800 opsys=bsd4-3
;;
- ;; Alpha (DEC) machines.
+ ## Alpha (DEC) machines.
alpha-dec-osf* )
machine=alpha opsys=osf1
;;
@@ -678,10 +678,12 @@ case "${canonical}" in
*-sunos5.4* | *-solaris2.4* )
opsys=sol2-4
NON_GNU_CPP=/usr/ccs/lib/cpp
+ RANLIB="ar -ts"
;;
*-sunos5.5* | *-solaris2.5* )
opsys=sol2-5
NON_GNU_CPP=/usr/ccs/lib/cpp
+ RANLIB="ar -ts"
;;
*-sunos5* | *-solaris* )
opsys=sol2
@@ -826,6 +828,10 @@ if test x"${opsys}" = x; then
esac
fi
+if test "x$RANLIB" = x; then
+ RANLIB=ranlib
+fi
+
changequote([, ])dnl
if test $unported = yes; then
@@ -1338,6 +1344,7 @@ AC_SUBST(CFLAGS)
AC_SUBST(X_TOOLKIT_TYPE)
AC_SUBST(machfile)
AC_SUBST(opsysfile)
+AC_SUBST(RANLIB)
AC_DEFINE_UNQUOTED(EMACS_CONFIGURATION, "${canonical}")
AC_DEFINE_UNQUOTED(EMACS_CONFIG_OPTIONS, "${ac_configure_args}")