summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKarl Heuer <kwzh@gnu.org>1995-12-21 07:59:49 +0000
committerKarl Heuer <kwzh@gnu.org>1995-12-21 07:59:49 +0000
commit513cb846c3b37cfc831b2b12f53d98a5d6d0d502 (patch)
tree6f2725dea1305a4ab5192db5f3691b4ce9828ef3 /configure.in
parent22611b583364dc9728ff54a4ea2a7ccee01b076d (diff)
downloademacs-513cb846c3b37cfc831b2b12f53d98a5d6d0d502.tar.gz
Just "solaris" now defaults to version 2.4.
Add sunos4.1.n-noshare as alternative.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 17 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 12c364c3805..7ca502c7be8 100644
--- a/configure.in
+++ b/configure.in
@@ -343,11 +343,17 @@ case "${canonical}" in
[56].[0-9] ) machine=nh4000 opsys=cxux ;;
[7].[0-9] ) machine=nh4000 opsys=cxux7 ;;
esac
+ NON_GNU_CPP="/lib/cpp"
;;
## Harris ecx or gcx running CX/UX (Series 1200, Series 3000)
m68k-harris-cxux* )
machine=nh3000 opsys=cxux
;;
+ ## Harris power pc NightHawk running Power UNIX (Series 6000)
+ powerpc-harris-powerunix )
+ machine=nh6000 opsys=powerunix
+ NON_GNU_CPP="cc -Xo -E -P"
+ ;;
## Honeywell XPS100
xps*-honeywell-sysv* )
@@ -670,7 +676,14 @@ case "${canonical}" in
opsys=sunos4shr
NON_GNU_CPP=/usr/lib/cpp
;;
- *-sunos4* | *-sunos ) opsys=sunos4-1
+ *-sunos4.1.[3-9]*-noshare )
+ opsys=sunos4-1-3
+ NON_GNU_CPP=/usr/lib/cpp
+ NON_GCC_TEST_OPTIONS=-Bstatic
+ GCC_TEST_OPTIONS=-static
+ ;;
+ *-sunos4* | *-sunos )
+ opsys=sunos4-1
NON_GCC_TEST_OPTIONS=-Bstatic
GCC_TEST_OPTIONS=-static
;;
@@ -689,7 +702,7 @@ case "${canonical}" in
RANLIB="ar -ts"
;;
*-sunos5* | *-solaris* )
- opsys=sol2
+ opsys=sol2-4
NON_GNU_CPP=/usr/ccs/lib/cpp
;;
* ) opsys=bsd4-2 ;;
@@ -1239,6 +1252,7 @@ if test "${HAVE_X11}" = "yes"; then
AC_CHECK_FUNCS(XrmSetDatabase XScreenResourceString \
XScreenNumberOfScreen XSetWMProtocols)
+ AC_CHECK_LIB(Xmu, XmuConvertStandardSelection)
fi
if test "${USE_X_TOOLKIT}" != "none"; then
@@ -1299,7 +1313,7 @@ if test $emacs_cv_localtime_cache = yes; then
AC_DEFINE(LOCALTIME_CACHE)
fi
-if test $HAVE_TIMEVAL = yes; then
+if test "x$HAVE_TIMEVAL" = xyes; then
AC_MSG_CHECKING(whether gettimeofday can't accept two arguments)
AC_TRY_LINK([
#ifdef TIME_WITH_SYS_TIME