summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRichard M. Stallman <rms@gnu.org>1995-12-25 01:23:18 +0000
committerRichard M. Stallman <rms@gnu.org>1995-12-25 01:23:18 +0000
commit94106e3200302b4f87db3ea06bf7da79d8ccd083 (patch)
tree9a547cce9a226d7746ac43e972ce215b12f6afc5 /configure.in
parentb6468730bbcb4aa1d5a3aff43189618fb3a05e9f (diff)
downloademacs-94106e3200302b4f87db3ea06bf7da79d8ccd083.tar.gz
Determine HAVE_X11R6.
(HAVE_MENUS): Renamed from HAVE_X_MENU.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 15 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 7ca502c7be8..a72e4b9f570 100644
--- a/configure.in
+++ b/configure.in
@@ -1032,9 +1032,9 @@ esac
X_TOOLKIT_TYPE=$USE_X_TOOLKIT
### If we're using X11, we should use the X menu package.
-HAVE_X_MENU=no
+HAVE_MENUS=no
case ${HAVE_X11} in
- yes ) HAVE_X_MENU=yes ;;
+ yes ) HAVE_MENUS=yes ;;
esac
if test "${opsys}" = "hpux9"; then
@@ -1255,6 +1255,17 @@ XScreenNumberOfScreen XSetWMProtocols)
AC_CHECK_LIB(Xmu, XmuConvertStandardSelection)
fi
+if test "${window_system}" = "x11"; then
+ AC_MSG_CHECKING(X11 version)
+ AC_TRY_LINK([#include <X11/Xlib.h>],
+[#if XlibSpecificationRelease < 6
+fail;
+#endif
+], [AC_MSG_RESULT(6)
+ AC_DEFINE(HAVE_X11R6)],
+ [AC_MSG_RESULT(not 6)])
+fi
+
if test "${USE_X_TOOLKIT}" != "none"; then
AC_MSG_CHECKING(X11 toolkit version)
AC_TRY_LINK([#include <X11/Intrinsic.h>],
@@ -1419,8 +1430,8 @@ fi
if test "${HAVE_XFREE386}" = "yes" ; then
AC_DEFINE(HAVE_XFREE386)
fi
-if test "${HAVE_X_MENU}" = "yes" ; then
- AC_DEFINE(HAVE_X_MENU)
+if test "${HAVE_MENUS}" = "yes" ; then
+ AC_DEFINE(HAVE_MENUS)
fi
if test "${GNU_MALLOC}" = "yes" ; then
AC_DEFINE(GNU_MALLOC)