summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKarl Heuer <kwzh@gnu.org>1995-05-29 19:52:41 +0000
committerKarl Heuer <kwzh@gnu.org>1995-05-29 19:52:41 +0000
commitaa1a518348141bacb74cbe44d806afc1297c7589 (patch)
tree95bfb1662b52d0125abf75cefd485b0969cebb33 /configure.in
parent29bef51f2d4a83527374488de6aeb06d283cf1e8 (diff)
downloademacs-aa1a518348141bacb74cbe44d806afc1297c7589.tar.gz
Allow x_libraries and x_includes to be paths.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 7f20db0eae3..f430b992e8a 100644
--- a/configure.in
+++ b/configure.in
@@ -932,11 +932,11 @@ else
fi
if test "${x_libraries}" != NONE && test -n "${x_libraries}"; then
- LD_SWITCH_X_SITE="-L${x_libraries}"
- LD_SWITCH_X_SITE_AUX="-R${x_libraries}"
+ LD_SWITCH_X_SITE=-L`echo ${x_libraries} | sed -e "s/:/ -L/g"`
+ LD_SWITCH_X_SITE_AUX=-R`echo ${x_libraries} | sed -e "s/:/ -R/g"`
fi
if test "${x_includes}" != NONE && test -n "${x_includes}"; then
- C_SWITCH_X_SITE="-I${x_includes}"
+ C_SWITCH_X_SITE=-I`echo ${x_libraries} | sed -e "s/:/ -I/g"`
fi
if test x"${x_includes}" = x; then