summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGerd Moellmann <gerd@gnu.org>2001-03-20 15:47:08 +0000
committerGerd Moellmann <gerd@gnu.org>2001-03-20 15:47:08 +0000
commitb7bfbdb6a6cc183f178db7bc2b247e7a0e914a4a (patch)
tree0946f781d38df262cc83b0a4593e99b87ca232ef /configure.in
parent6d980504220eb2d7d8a3054ec4106a638bc4db2b (diff)
downloademacs-b7bfbdb6a6cc183f178db7bc2b247e7a0e914a4a.tar.gz
(HAVE_XPM): Don't print the result of the check for
XpmReturnAllocPixels if we don't have an xpm.h.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 10 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 460d1b31d06..00d283daac5 100644
--- a/configure.in
+++ b/configure.in
@@ -1811,18 +1811,19 @@ if test "${HAVE_X11}" = "yes"; then
AC_CHECK_HEADER(X11/xpm.h,
AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, HAVE_XPM=yes, , -lX11))
if test "${HAVE_XPM}" = "yes"; then
- AC_MSG_CHECKING(for XpmReturnAllocPixels preprocessor define)
- AC_EGREP_CPP(no_return_alloc_pixels,
- [#include "X11/xpm.h"
+ AC_MSG_CHECKING(for XpmReturnAllocPixels preprocessor define)
+ AC_EGREP_CPP(no_return_alloc_pixels,
+ [#include "X11/xpm.h"
#ifndef XpmReturnAllocPixels
no_return_alloc_pixels
#endif
- ], HAVE_XPM=no, HAVE_XPM=yes)
- fi
- if test "${HAVE_XPM}" = "yes"; then
- AC_MSG_RESULT(yes)
- else
- AC_MSG_RESULT(no)
+ ], HAVE_XPM=no, HAVE_XPM=yes)
+
+ if test "${HAVE_XPM}" = "yes"; then
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+ fi
fi
fi